Find the answer to your Linux question:
Results 1 to 8 of 8
Distribution: Arch Linux 2010.05 Kernal: 2.6.33.4 System Info: Intel Core2Duo 1.8GHz 2GB Crucial DDR2 667MHZ RAM ASrock 775-DualVSTA Motherboard NVIDIA 8800GT 512MB PCI-Express Graphics Card 500GB SATA Western Digital Caviar ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38

    Permission Problems Gnome with Arch Linux


    Distribution:Arch Linux 2010.05
    Kernal:2.6.33.4

    System Info:
    Intel
    Core2Duo 1.8GHz
    2GB Crucial DDR2 667MHZ RAM
    ASrock 775-DualVSTA Motherboard
    NVIDIA
    8800GT 512MB PCI-Express Graphics Card
    500GB SATA Western Digital Caviar Blue (MAIN SYSTEM DRIVE)
    250GB IDE Western Digital Caviar
    300GB SATA WEstern Digital Caviar RE16
    160GB IDE Maxtor Diamondmax Plus 9
    500W Casecom power supply


    Hello All,

    I've recently switched to linux full time using Arch with a fresh install and im still trying to get everything configured properly.

    One of the problems i'm having relates to permissions. I've currently got my main 500GB SATA hard drive (see details in system info) and my 250GB IDE (see system info) drive plugged in, with all the others unplugged. On the 250GB HDD ive got all my backups of music and films that I want to transfer back to my 500Gig hdd. The problem i'm having is 1. I can't create any new partitions on my 500gig hard drive because when I enter the Disk Utility (in gnome) and try and create a new partition, I get the message:

    Error Creating Partition:

    An error occurred while performing an operation on "500GB Hard Disk": Permission Denied.

    Details:
    Not Authorised.
    So it obviously wants me to be root to do this, but why? and how do I become root whilst using a program like that. I've seen it before when it asks you for a password for root in a dialogue box, but Arch doesn't seem to be doing this.

    Second problem, still relating to permissions, is when I try and view the 250Gig backup drive through "Places>Computer>Backupdrive", I get the error:

    Folder Contents Could Not Be Displayed:

    You do not have the permissions necessary to view the contents of "backupdrive".
    If I mount it using the fstab, I still get the same messages.

    Has anyone got any ideas how to solve this.

    Thanks,
    Scott.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    The easiest way (in my opinion) to work with partitions is to use gparted while running the Parted Magic LiveCD. Doing it this way, you don't run into problems due to permissions issues and mounted partitions.
    oz

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    Thanks Ozar,

    I was trying to use gnomes Disk Utility, which I thought would be sufficient and give me root privileges to be able to make alterations, but obviously its not, unless I run it from the command line using something like sudo or gksu.

    Instead, i've installed gparted along with gksu, which ive always used in the past anyway, whether on a liveCD or within a distro. It gives a root password prompt as soon as it launches and then theres no problems following that.


    Thanks for the help Ozar,
    Scott.

  4. $spacer_open
    $spacer_close
  5. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Right... the times that I've tried using Disk Utility gave problems as well. Gparted seems to work far better for me, especially when run from a liveCD environment.
    oz

  6. #5
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    Following on to the second part of my first post about permissions for mounting the partitions:

    I have managed to get mounting working for the NTFS drive, I had to install ntfs-3g and then it allowed me to mount. I have now added all the drives to fstab to automount on boot, but the problem im having now is that I cant copy and paste files on or between any of the mounted partitions, even though I have added the rw option to fstab. My fstab looks like the following:

    #
    # /etc/fstab: static file system information
    #
    # <file system> <dir> <type> <options> <dump> <pass>
    devpts /dev/pts devpts defaults 0 0
    shm /dev/shm tmpfs nodev,nosuid 0 0

    #/dev/cdrom /media/cd auto ro,user,noauto,unhide 0 0
    #/dev/dvd /media/dvd auto ro,user,noauto,unhide 0 0
    #/dev/fd0 /media/fl auto user,noauto 0 0

    /dev/sda1 /boot ext4 defaults 0 1
    /dev/sda2 / ext4 defaults 0 1

    /dev/sda5 /mnt/Music ext4 rw,user,auto 0 0
    /dev/sda6 /mnt/Media ext4 rw,user,auto 0 0

    /dev/sdb1 /mnt/backupdrive ntfs-3g rw,user,auto 0 0
    Does my fstab look ok? Is there anything in there that is bad practice? And is it ok to mount the drives to /mnt/"name", or is this bad practice? Anyone ideas on why it seems that I can't write to or from any of the mounted partitons?

    Thanks,
    Scott.

  7. #6
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Sorry, I don't do any NTFS filesystems at all and don't know much about ntfs-3g other than what it is so I can't help much with that, but the Arch wiki has a page specifically for fstab that might help:

    fstab - ArchWiki
    oz

  8. #7
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    Managed to sort the read write problems. Just had to do chmod 777 /mnt/Media and chmod 777 /mnt/Music and it sorted the permissions out. Its because ext2/3/4 isn't affected by the rw option in fstab, the rw option is only for ntfs and fat (iirc?).

    I'm not entirely sure what the chmod 777 command does as i've not had time to read the wiki yet, its a permission option but what the 777 does i have no idea, but I will be sure to check the wiki out when I have a minute.


    Many thanks again,
    Scott.

  9. #8
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    chmod 777 changes the permissions to grant read, write, and execute privileges to everyone. Generally not what you want. You usually will at least want to restrict who can execute files for security.

    Understanding Linux File Permissions | Linux.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •