Find the answer to your Linux question:
Results 1 to 2 of 2
Okay, I am having a very strange issue that I've never seen before. For some reason, I cannot open up any document that is associated with Open Office off of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    5

    Exclamation Cannot open docs off of network share


    Okay, I am having a very strange issue that I've never seen before. For some reason, I cannot open up any document that is associated with Open Office off of a network share. Whenever I try to do so, I get the following message:

    Could not display "smb://192.168.1.105/z_drive/Information2.doc".
    There is no application installed for Word document files

    I can copy the document to the desktop and it'll open up just fine. This is only happening when trying to open documents on that share that are associated with Open Office. All other files (media files, pdf files, etc..) will open fine.

    I have tried removing Open Office and reinstalling it, but that hasn't solved this strange problem.

    This is on an Ubuntu workstation, fwiw.

    I "mapped" the share by going to Places -> Server -> Windows Share -> and putting in my credentials that way.

    Thanks in advance.
    Attached Images Attached Images

  2. #2
    Just Joined!
    Join Date
    Sep 2010
    Posts
    2

    Re: Cannot open docs off of network share

    I would assume some part of the application chain (I'm guessing the file manager) figures that a smb://... URL cannot be "just" opened -- the program that is supposed to open it (OpenOffice in this case) would need "special" Samba support to be able to do this.

    "The" way to enable *any* program to open the file would probably be mounting the share into the "normal" filesystem tree, i.e.

    sudo mkdir /mnt/smb
    sudo mount //192.168.1.105/z_drive /mnt/smb -ousername=YourUserName,password=YourPassword
    oowriter /mnt/smb/Information2.doc # or whatever the word processor is called these days

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •