Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, Using OS GNU/Linux, version ('uname -a' output): Linux [hostname] 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i586 GNU/Linux. Problem with application Lynx command-line text-only web browser, version ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    5

    Question Lynx Web Browser and Google.


    Hi,

    Using OS GNU/Linux, version ('uname -a' output):
    Linux [hostname] 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i586 GNU/Linux.

    Problem with application Lynx command-line text-only web browser, version ('lynx --version' output):
    Lynx Version 2.8.7pre.6 (23 Jun 2009)
    libwww-FM 2.14, SSL-MM 1.4.1, ncurses 5.7.20090803(wide)
    Built on linux-gnu Jun 25 2009 07:16:26.

    I can't get Google's web page to display (neither Google's main site or their UK one). Instead, Lynx says 'application/x-gzip' D)ownload, or C)ancel'. Out of curiosity, I downloaded to a file and found the file contains gobbledegook characters (binary data?). Here's the output from a Gnome terminal under X:

    Looking up 'google.com' first

    Looking up google.com first
    Looking up google.com
    Making HTTP connection to google.com
    Sending HTTP request.
    HTTP request sent; waiting for response.
    HTTP/1.1 301 Moved Permanently
    Data transfer complete
    HTTP/1.1 301 Moved Permanently
    Using [Google's main site URL]
    Looking up [Google's main site URL]
    Making HTTP connection to [Google's main site URL]
    Sending HTTP request.
    HTTP request sent; waiting for response.
    HTTP/1.0 302 Moved Temporarily
    Allowing this cookie.
    Allowing this cookie.
    Data transfer complete
    HTTP/1.0 302 Moved Temporarily
    Using [Google's UK site URL]
    Looking up [Google's UK site URL]
    Making HTTP connection to [Google's UK site URL]
    Sending HTTP request.
    HTTP request sent; waiting for response.
    HTTP/1.0 200 OK
    Allowing this cookie.
    Allowing this cookie.
    Allowing this cookie.
    Data transfer complete
    /usr/bin/file-roller '/tmp/lynxXXXXnNDUYj/L4165-4181TMP.bin'

    lynx: Start file could not be found or is not text/html or text/plain
    Exiting....

    The 'file-roller' command invokes a graphical 'Archive Manager' which I exited and then got the rest of the Lynx output. I also use Links and ELinks without any problem. I suspect it is a MIME-type issue but I don't know a simple way to fix it. I had a problem before with Google returning an error because Lynx was sending a ton of MIME information to the site and I think I had to do something with the MAILCAP MIME-type list. I really like Lynx as well.

    Can anyone help, please?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,533
    If the page is trying to load/run a client-side java script (jsp), then you may be out of luck here. Anyway, I just looked at the standard Google search page, and it seems to contain embedded java script code. Since it isn't standard HTML, Lynx may not play nice with it.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,533
    Yeah - the new "improved"* Google uses a lot of Javascript


    * They are sarcastic quote marks
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  4. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Hmm, lynx works fine with google for me.

  5. #5
    Just Joined!
    Join Date
    Aug 2010
    Posts
    5

    Smile Solved!

    Funnily enough, now it works after going through a reboot or two.

    FWIW, I'd had no problems with my two 'remote' machines (ie: on my LAN) running Mandrake/Mandriva 10.0 and their Lynxes/Linkses:

    (OS:) Linux [hostname] 2.6.3-7mdk #1 Wed Mar 17 15:56:42 CET 2004 i586 unknown unknown GNU/Linux

    (Lynx:) Lynx Version 2.8.5rel.1 (04 Feb 2004)
    libwww-FM 2.14, SSL-MM 1.4.1, OpenSSL 0.9.7c
    Built on linux-gnu Feb 6 2004 03:09:17

    (Links:) Links 2.1pre13.

    Dunno what was up.
    Last edited by gazza11; 09-25-2010 at 09:46 PM. Reason: Overlooked default stupid smiley conversion of characters.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •