Find the answer to your Linux question:
Results 1 to 4 of 4
I am new to Linux and programing languages and general and am trying to install Kismet. I have the .tar.gz archive downloaded from the kismet website, but have no idea ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2010
    Posts
    2

    Kismet help (in Linux newbie speak please)


    I am new to Linux and programing languages and general and am trying to install Kismet. I have the .tar.gz archive downloaded from the kismet website, but have no idea what the next step is.
    Can anyone help me?

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome.
    Do you have a working Internet connection available in Linux? If so, you need to find the package manager for your system and use that to install Kismet...it will save you a lot of time and trouble.
    Which distro are you using?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Nov 2010
    Posts
    2
    yes, I have an active Internet connection, and have Linux Mint dual-installed as a partition alongside Windows 7. I had already installed Kismet using the package manager, but when I try to run it in Terminal, I get a message of:
    Launching kismet_server: //usr/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    FATAL: Unable to set up pidfile /var/run//kismet_server.pid, unlink() failed: Permission denied
    Done.


    so the next thing I tried was running sudo kismet, but then i get this:
    [sudo] password for <my username>:
    Launching kismet_server: //usr/bin/kismet_server
    Suid priv-dropping disabled. This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
    Enabling channel hopping.
    Enabling channel splitting.
    NOTICE: Disabling channel hopping, no enabled sources are able to change channel.
    Source 0 (addme): Opening none source interface none...
    FATAL: Please configure at least one packet source. Kismet will not function if no packet sources are defined in kismet.conf or on the command line. Please read the README for more information about configuring Kismet.
    Kismet exiting.
    Done.

    however, i cannot find kismet.conf or the readme, and decided to try to manually install it, which was a lot more complicated than i thought.
    I am starting to think that my WiFi card simply is not adequate for network monitoring, as kismet (in my Windows) also gives errors, Wireshark doesn't give any interface options in Linux, but does in Windows, and Firesheep (firefox extension) only shows packets from my computer, as opposed to all traffic, when I run it. But those are off topic :)

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Let's see what your wireless card and driver are.

    Post the output of
    Code:
    sudo lshw -C network
    The conf file should be at /etc/kismet/kismet.conf

    Open that file in a text editor with root permissions
    Code:
    gksudo gedit /etc/kismet/kismet.conf
    Find the line beginning with source=

    Change to
    Code:
    source=driver name,interface name,network broadcast name
    The interface name is often wlan0, but may vary. To find the inteface name, check the output of
    Code:
    iwconfig
    So if I were using an atheros wireless card with the ath9k driver on wlan0 on the network MyHome, it would look like
    Code:
    source=ath9k,wlan0,MyHome
    Save and exit the editor and run
    Code:
    sudo kismet

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •