Find the answer to your Linux question:
Results 1 to 2 of 2
well i suppose this makes the problem ever more complex because i'm acutally attempting to make a cross compile tool chain from amd64 to arm. i've successfully built binutils and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    24

    [SOLVED] gcc make error, missing 'libgcc.mvars'


    well i suppose this makes the problem ever more complex because i'm acutally attempting to make a cross compile tool chain from amd64 to arm.
    i've successfully built binutils and configured the kernel headers. now i'm stuck on gcc
    i'm running
    Code:
    sudo make -j 4
    when i get the issue (the -j 4 if you don't know helps speed up the process considerably by using more threads)
    anyways it tells me:
    Code:
    make[2]: Entering directory `/home/alex/tmp/gcc-4.4.5/arm-linux/libgcc'
    Makefile:143: ../.././gcc/libgcc.mvars: No such file or directory
    make[2]: *** No rule to make target `../.././gcc/libgcc.mvars'.  Stop.
    make[2]: Leaving directory `/home/alex/tmp/gcc-4.4.5/arm-linux/libgcc'
    make[1]: *** [all-target-libgcc] Error 2
    make[1]: Leaving directory `/home/alex/tmp/gcc-4.4.5'
    make: *** [all] Error 2
    when i configured gcc i ran:
    Code:
    ./configure --target=arm-linux --disable-threads --enable-languages=c
    the headers i pulled from kernel 2.6.36, gcc is obviously 4.4.5 (both my currently installed version and the version i'm trying to compile) and binutils is version 2.21 (again both my currently installed version and the version i compiled and am using to compile gcc)

    from googleing i gathered its probably the way i configured gcc but when i read the documentation, i'm pretty sure what i did was correct (which is why i'm asking about it here, maybe i slipped up and can't see it)

  2. #2
    Just Joined!
    Join Date
    Dec 2009
    Posts
    24
    ok. i figured out what i did. i needed to create a separate build directory. but then i ran into another error (i can't recall the specific file but it was lib_a.so with something after the lib part) and i added --disable-shared to the configure arguments. then i used 'make all-gcc' rather then 'make' and again instead of 'make install' i used 'make install-gcc'
    and everything seems to be working.
    (the cross linux from scratch book was helpful as well...i had forgotten about it.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •