Find the answer to your Linux question:
Results 1 to 7 of 7
I would like to change an email account from POP3 to IMAP on an ISPConfig 2 system, I can see that the IMAP and POP3 process are both running. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    5

    POP3 to IMAP on ISPConfig 2


    I would like to change an email account from POP3 to IMAP on an ISPConfig 2 system, I can see that the IMAP and POP3 process are both running.

    I have the Maildir check box ticked for the server

    Is there anything else I need to do, or is it just a case of changing the mail client from expecting POP3 to expecting IMAP?
    Thanks

  2. #2
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    If the imap server is otherwise correctly configured, then yes, you should just be able to switch the client to imap. Do you know whether the imap server is v2 or v3? v2 defaults to port 143, v3 to 220. You may need to experiment with version or port options if you don't have initial success.

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    5
    Thanks for the response

    I have looked in the courier directories and can find no reference to either v2 or v3.

    netstat shows me that *.imaps and *.imap2 are listening but there is no mention of port 143 or 220.

    ps shows that imapd is running

    Telnet to both ports result in a Connect failed

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    5
    Hello

    I have moved a stage further, I now know that the IMAP server is running, it is actually Courier IMAP and initial access to it is through couriertcpd which is listening to port 143.

    I can telnet to the port using 127.0.0.1 but cannot do so remotely, therefore it must be a firewall issue

    Any pointers on where to look next ?

  6. #5
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Not necessarily firewall, it's possible Courier is only listening on 127.0.0.1.
    netstat -ntpl
    can help with that. Do you see 127.0.0.1:143 on a courier line, or is it 0.0.0.0:143 (i.e. a wildcard to listen to all addresses)? I use Dovecot instead of Courier, so I can't tell you where the setting is offhand.

  7. #6
    Just Joined!
    Join Date
    Mar 2005
    Posts
    5
    Bingo

    It turned out to be a combination of both, Courier was in fact just listening to 127.0.0.1:143 so I modified the -address parameter for couriertcpd, when this still did not work, I found that port 143 was not in the list of open ports in the firewall, with that open it is now working fine.
    Many thanks for your help

  8. #7
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Glad to have been able to contribute. It's not often that being half right solves half the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •