I am using logrotate version 3.7 for my syslog rotation. My /etc/logrotate.conf contents are:

create
include /etc/logrotate.d

/var/log/apps.log {
rotate 1
size 100k
postrotate
/bin/kill -HUP `cat /var/run/syslogd.pid 2> /dev/null` 2> /dev/null || true
endscript
}

When I execute the logrotate command with comamnd : /usr/sbin/logrotate -v /etc/logrotate.conf

I see following error:

reading config file /etc/logrotate.conf
including /etc/logrotate.d
reading config info for /var/log/apps.log

Handling 1 logs

rotating pattern: /var/log/apps.log 102400 bytes (1 rotations)
empty log files are rotated, old logs are removed
considering log /var/log/apps.log
log needs rotating
rotating log /var/log/apps.log, log->rotateCount is 1
renaming /var/log/apps.log.1 to /var/log/apps.log.2 (rotatecount 1, logstart 1, i 1),
old log /var/log/apps.log.1 does not exist
renaming /var/log/apps.log.0 to /var/log/apps.log.1 (rotatecount 1, logstart 1, i 0),
old log /var/log/apps.log.0 does not exist
log /var/log/apps.log.2 doesn't exist -- won't try to dispose of it
renaming /var/log/apps.log to /var/log/apps.log.1
creating new log mode = 0664 uid = 0 gid = 16
running postrotate script
logrotate.b7HC2p: applet not found
error: error running postrotate script

I tried changing the statement after postrotate to simeple echo statement or ls command but nothings works. I keep on getting the same error. Could anyone help in this ?