Find the answer to your Linux question:
Results 1 to 7 of 7
I need help with pianobar, It's been working since I installed it six months ago then abruply it stoped on all my computers I think I might need to upgrade ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Aug 2010
    Posts
    233

    [SOLVED] pianobar


    I need help with pianobar,
    It's been working since I installed it six months ago then abruply it stoped on all my computers I think I might need to upgrade pianobar but I don't know how.

    code:

    User@UserMint ~ $ pianobar
    Welcome to pianobar (2010.10.07)! Press ? for a list of commands.
    [?] Username: User@yahoo.com
    [?] Password: ********
    (i) Login... Error: Protocol incompatible. Please upgrade libpiano.

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,115
    I'm getting the same crap with

    ~$ apt-cache policy pianobar
    pianobar:
    Installed: (none)
    Candidate: 2011.01.24-1
    Version table:
    2011.01.24-1 0
    500 Index of /debian testing/main i386 Packages
    Which Candidate: 2011.01.24-1 is pretty much the most recent. I think pandora radio is tied in with that error. You can in Ubuntu do a

    Code:
    sudo apt-get update
    when done. do a

    Code:
    apt-cache policy pianobar
    and see if Ubuntus version matches mine. If it does. Upgrading will probably give the same libpiano message. That error is tied in with the pianobar package and the developer is the one that needs to fix it. If wanting to try upgrade anyway. After doing apt-get update. Look in synaptic package manager in search for pianobar. Right click and pick upgrade if it is available.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Linux Newbie
    Join Date
    Aug 2010
    Posts
    233
    I have version 2010.10.07-lubuntu0.1(maaveric-updates)
    I tried to force Version to 2011 but its not listed I've run an update so I don't know why I cant get 2011.

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,115
    Maverick Ubuntu only has 2010 version

    Ubuntu -- Details of package pianobar in maverick

    So I guess you will have to download Natty Narwhals deb and install with gdebi.

    Ubuntu -- Details of package pianobar in natty

    Trouble is. That version gave me the same libpiano error message in AntiX which uses the same pianobar as Natty. You can try it out though. You can always unistall it via synaptic package manager after install if it won't work out for you.

    Edit: Tried pithos also. No joy with pandora there either. Pandora radio changes how it interfaces with pianobar and breaks it. So more pandoras fault than pianobar.

    Edit: Read my below post before trying this out.
    Last edited by rokytnji; 05-02-2011 at 11:23 PM.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,115
    After uninstalling pithos. I checked again pianobar in my distro after a apt-get update and saw that

    Candidate: 2011.01.24-2
    was available. Sooooooooo

    Code:
    # apt-get install pianobar
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Suggested packages:
      libaudio-scrobbler-perl
    The following NEW packages will be installed:
      pianobar
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 51.7 kB of archives.
    After this operation, 180 kB of additional disk space will be used.
    Get:1 http://ftp.us.debian.org/debian/ testing/main pianobar i386 2011.01.24-2 [51.7 kB]
    Fetched 51.7 kB in 0s (64.0 kB/s)
    Selecting previously deselected package pianobar.
    (Reading database ... 73745 files and directories currently installed.)
    Unpacking pianobar (from .../pianobar_2011.01.24-2_i386.deb) ...
    Processing triggers for man-db ...
    Setting up pianobar (2011.01.24-2) ...
    # exit
    exit
    bikertest4:~$ pianobar
    Welcome to pianobar (2011.01.24)! Press ? for a list of commands.
    [?] Username: rok
    [?] Password: 
    (i) Login... Ok.
    (i) Get stations... Ok.
    	 0)     AC/DC Radio
    	 1)     Audioslave Radio
    	 2)     Avenged Sevenfold Radio
    	 3)     Buckcherry Radio
    	 4)     Charlie Sexton Radio
    	 5)     Chris Rea Radio
    	 6)     Depeche Mode Radio
    	 7)     Evanescence Radio
    	 8)     Faith No More Radio
    	 9)     Gary Numan/Tubeway Army Radio
    	10)     Gorillaz Radio
    	11)  Q  rokys QuickMix
    	12)     Hoobastank Radio
    	13)     Les Claypool Radio
    	14)     Little Feat Radio
    	15)     Marilyn Manson Radio
    	16)     Nickelback Radio
    	17)     Nine Inch Nails Radio
    	18)     Puddle Of Mudd Radio
    	19)     Savoy Brown Radio
    	20)     Seether Radio
    	21)     Stevie Ray Vaughan Radio
    	22)     The Black Keys Radio
    	23)     The Cult Radio
    	24)     The Fabulous Thunderbirds Radio
    	25)     Thin Lizzy Radio
    	26)     Thousand Foot Krutch Radio
    	27)     ZZ Top Radio
    [?] Select station: 25
    |>  Station "Thin Lizzy Radio" (375328559185954194)
    (i) Receiving new playlist... Ok.
    |>  "Old Flame" by "Thin Lizzy" on "Johnny The Fox"
    #   -02:45/03:05
    |>  "Going To California" by "Led Zeppelin" on "Led Zeppelin IV"
    #   -02:56/03:31
    then I did in another terminal

    Code:
    # apt-get install   libaudio-scrobbler-perl
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following extra packages will be installed:
      libconfig-inifiles-perl
    The following NEW packages will be installed:
      libaudio-scrobbler-perl libconfig-inifiles-perl
    0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 63.7 kB of archives.
    After this operation, 254 kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://ftp.us.debian.org/debian/ testing/main libconfig-inifiles-perl i386 2.58-1 [47.9 kB]
    Get:2 http://ftp.us.debian.org/debian/ testing/main libaudio-scrobbler-perl i386 0.01-2.1 [15.9 kB]
    Fetched 63.7 kB in 1s (55.4 kB/s)               
    Selecting previously deselected package libconfig-inifiles-perl.
    (Reading database ... 73761 files and directories currently installed.)
    Unpacking libconfig-inifiles-perl (from .../libconfig-inifiles-perl_2.58-1_i386.deb) ...
    Selecting previously deselected package libaudio-scrobbler-perl.
    Unpacking libaudio-scrobbler-perl (from .../libaudio-scrobbler-perl_0.01-2.1_i386.deb) ...
    Processing triggers for man-db ...
    Setting up libconfig-inifiles-perl (2.58-1) ...
    Setting up libaudio-scrobbler-perl (0.01-2.1) ...
    for good measure. I run Debian testing and Sid repositories in AntiX.
    Code:
    ~$ inxi -r
    Repos:     Active apt sources in file: /etc/apt/sources.list
               deb http://ftp.us.debian.org/debian/ testing main contrib non-free
               deb http://security.debian.org/ testing/updates main contrib non-free
               deb http://liquorix.net/debian/ sid main
    You might just have to wait till Ubuntu catches up to pianobar 2011.01.24-2
    because that version now plays pandora radio for me till friggin pandora radio changes their interface andf breaks it again. You could try going to pianobars site and installing the latest from source. A video for installing pianobar from source in Ubuntu is on youtube.

    Edit: or take a chance with >> Ubuntu >> Packages >> oneiric >> sound >> pianobar

    which has version Package: pianobar (2011.01.24-2)

    2nd Edit: Read Below before trying what is in this post
    Last edited by rokytnji; 05-03-2011 at 02:54 AM.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  6. #6
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,115
    Ok. I booted up my Ubuntu 10.04 LTS Desktop. Uninstalled old pianobar first with

    Code:
    sudo apt-get remove pianobar
    Then went and downloaded (I use 64bit Ubuntu which is amd64 download. If you are using 32 bit Ubuntu. Use the i386 download).

    Code:
    ~$ inxi -F
    System:    Host owner-desktop Kernel 2.6.32-31-generic x86_64 (64 bit) Distro Ubuntu 10.04 lucid
    CPU:       Dual core AMD Athlon 64 X2 4200+ (-MCP-) cache 1024 KB flags (lm nx sse sse2 sse3 svm) bmips 8800.7 
               Clock Speeds: (1) 2200.175 MHz (2) 2200.175 MHz
    Graphics:  Card: nVidia G71 [GeForce 7900 GS] bus-ID: 01:00.0 X.Org 1.7.6 Res: 1024x768@50.0hz 
               GLX Renderer GeForce 7900 GS/PCI/SSE2 GLX Version 2.1.2 NVIDIA 195.36.24 Direct Rendering Yes
    Audio:     Card ATI SBx00 Azalia (Intel HDA) driver HDA Intel bus-ID: 00:14.2
               Sound: Advanced Linux Sound Architecture Version 1.0.21
    Network:   Card Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver r8169 v: 2.3LK-NAPI port dc00 bus-ID: 02:00.0
    Disks:     HDD Total Size: 320.1GB (12.3% used) 1: /dev/sda WDC_WD3200AAKS 320.1GB 
    Partition: ID:/ size: 288G used: 37G (14%) fs: ext4 ID:swap-1 size: 6.17GB used: 0.00GB (0%) fs: swap 
    Sensors:   System Temperatures: cpu: 41.0C mobo: 37.0C gpu: 0.0:58C 
               Fan Speeds (in rpm): cpu: 5625 psu: 0 sys-1: 995 
    Info:      Processes 173 Uptime 19 min Memory 830.0/2008.5MB Runlevel 2 Client Shell inxi 1.4.95
    I downloaded the

    Ubuntu -- Details of package pianobar in oneiric

    Installed with gdebi.

    Checked new veersion number to be sure

    Code:
    :~$ apt-cache policy pianobar
    pianobar:
      Installed: 2011.01.24-2
      Candidate: 2011.01.24-2
      Version table:
     *** 2011.01.24-2 0
            100 /var/lib/dpkg/status
    Then I ran pianobar

    Code:
    owner@owner-desktop:~$ pianobar
    Welcome to pianobar (2011.01.24)! Press ? for a list of commands.
    [?] Username: rok
    [?] Password: 
    (i) Login... Ok.
    (i) Get stations... Ok.
    	 0)     AC/DC Radio
    	 1)     Audioslave Radio
    	 2)     Avenged Sevenfold Radio
    	 3)     Buckcherry Radio
    	 4)     Charlie Sexton Radio
    	 5)     Chris Rea Radio
    	 6)     Depeche Mode Radio
    	 7)     Evanescence Radio
    	 8)     Faith No More Radio
    	 9)     Gary Numan/Tubeway Army Radio
    	10)     Gorillaz Radio
    	11)  Q rokys QuickMix
    	12)     Hoobastank Radio
    	13)     Les Claypool Radio
    	14)     Little Feat Radio
    	15)     Marilyn Manson Radio
    	16)     Nickelback Radio
    	17)     Nine Inch Nails Radio
    	18)     Puddle Of Mudd Radio
    	19)     Savoy Brown Radio
    	20)     Seether Radio
    	21)     Stevie Ray Vaughan Radio
    	22)     The Black Keys Radio
    	23)     The Cult Radio
    	24)     The Fabulous Thunderbirds Radio
    	25)     Thin Lizzy Radio
    	26)     Thousand Foot Krutch Radio
    	27)     ZZ Top Radio
    So the oneiric Ubuntu works in my Ubuntu 10.04LTS. So It should work in your Maverick (I hope).
    Last edited by rokytnji; 05-03-2011 at 02:57 AM.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  7. #7
    Linux Newbie
    Join Date
    Aug 2010
    Posts
    233
    I use Mint 10 and what you did worked for me!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •