Find the answer to your Linux question:
Results 1 to 3 of 3
I am running centos 5.5 and just tried to install phpMyAdmin using yum. yum install phpmyadmin It installed successfully however now when I go to mydomain.com/phpmyadmin I get a Forbidden ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    2

    Install phpMyAdmin Yum Error Forbidden Access


    I am running centos 5.5 and just tried to install phpMyAdmin using yum.

    yum install phpmyadmin

    It installed successfully however now when I go to mydomain.com/phpmyadmin I get a Forbidden error. You don't have permission to access /phpmyadmin on this server.

    I don't see a sub folder within /var/www/html called phpMyAdmin its seems its in /usr/share/phpMyAdmin

    I believe the permissions are set correctly on /usr/share/phpMyAdmin: drwxr-xr-x 9 root root 4096 May 5 15:47 phpMyAdmin


    Should I have installed this using a different method?

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,110
    Did you restart apache after installing phpMyAdmint?
    I don't use Fedora but there are numerous tutorials for installing a Lamp server w/or without phpMyadmin. Here's one:

    Installing Apache2 With PHP5 And MySQL Support On Fedora 11 (LAMP) | HowtoForge - Linux Howtos and Tutorials

    The above link states Fedora 11 but the sites I checked for Fedora 14 were the same as far as I could tell. If this sites info doesn't work, googling will put lots of sites. You are using Fedora??

  3. #3
    Just Joined!
    Join Date
    May 2011
    Posts
    2

    Talking Thank You - SOLVED

    The tutorial did point me in the right direction. The section within it witch stated to comment out:

    #<Directory /usr/share/phpMyAdmin/>
    # order deny,allow
    # deny from all
    # allow from 127.0.0.1
    # allow from ::1
    #</Directory>


    I did before, but for some reason when I went back into the phpmyadmin.conf file it listed the part I commented out AND it had replaced itself with the same text uncommented out. Very odd that there were 2 entries in there...at any rate its working now. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •