Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Application requires later glibc

    My users need to run an application which was build with newer GLIBC_2.11, while my system only gets GLIBC_2.4. It shows error "cannot find GLIBC_2.11" whenever I run it. I cannot upgrade the system, so I have tried building Glibc 2.11 (for example:/opt/glibc-2.11) to another directory, but when I point LD_LIBRARY_PATH to /opt/glibc-2.11, I cannot run any commands because of error invalid LFS ABI. I also tried using LD_PRELOAD, but it does not work. Please help me, how can I fix this problem?
    Thanks so much!

  2. #2
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Harrow, UK
    Try ldconfig /opt/lib. That should add /opt/lib to your library path without altering the status of /lib and /usr/lib (which contain the libraries that everything else is linked to).
    "I'm just a little old lady; don't try to dazzle me with jargon!"

  3. #3
    I have got the solution with patchelf, thanks to a member of linuxquestions.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts