Find the answer to your Linux question:
Results 1 to 4 of 4
I tried to install my hardware drivers for wireless internet connection- with the following information: but I am not able to - please where did I do mistake " Problem ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! High_Lander's Avatar
    Join Date
    Jan 2010
    Posts
    23

    Thumbs up Installation of hardware driver from zip file


    I tried to install my hardware drivers for wireless internet connection- with the following information: but I am not able to - please where did I do mistake

    "Problem using Broadcom Wireless in Ubuntu 9.10/10.04 because it is not supported by b43 driver ?

    Assuming you have tried all normal installation procedures like using the Hardware Drivers tool and you still do not have a working WiFi setup this is what you must do:

    1. Download the Broadcom drivers: Broadcom.com - 802.11 Linux STA driver
    2. Unpack and modify the ‘src/wl/sys/wl_linux.c‘:
    Line 35 (after #include <linux/etherdevice.h>) add:

    #include < linux/sched.h >

    3. Compile the code with: make
    4. Copy the new driver: sudo mv wl.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless
    5. Update dependencies: sudo depmod -a
    6. Modify the blacklist to include the ‘b43′ and ’ssb’ drivers /etc/modprobe.d/blacklist.conf (Add below the bcm43xx blacklist)



    I thought I followed the same procedure but could not do it: the results are as given below



    root@ntd-laptop:/home/ntd/Desktop/src/wl/sys# ls
    wlc_key.h wlc_types.h wl_export.h wl_iw.h wl_linux.h
    wlc_pub.h wl_dbg.h wl_iw.c wl_linux.c
    root@ntd-laptop:/home/ntd/Desktop/src/wl/sys# make wl_linux.c
    make: Nothing to be done for `wl_linux.c'.
    root@ntd-laptop:/home/ntd/Desktop/src/wl/sys# cd

    root@ntd-laptop:~# cd /home/ntd/Desktop/
    root@ntd-laptop:/home/ntd/Desktop# cd src
    root@ntd-laptop:/home/ntd/Desktop/src# cd wl
    root@ntd-laptop:/home/ntd/Desktop/src/wl# cd
    root@ntd-laptop:~# make
    make: *** No targets specified and no makefile found. Stop.
    root@ntd-laptop:~# make wl
    make: *** No rule to make target `wl'. Stop.
    root@ntd-laptop:~#

    I could not go further - please suggest me -

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I've never done this or used those drives but, it looks to me like you skipped Step 2 unless you just left it out of your post. Did you add the line referred to in that step:
    #include < linux/sched.h >

    Maybe I'm misreading your post?

  3. #3
    Just Joined! High_Lander's Avatar
    Join Date
    Jan 2010
    Posts
    23

    Installation of hardware driver from zip file

    Yes - I did
    I don't know whether understood the question or you're just trying to be a smart alec?

    In any case, even if I did or did not add the line- but I could no the compilation

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Your output in the original post shows no make file found and your ls output show no make file which should be there. I'm not really that familiar with wireless and have neveer used Broadcom so maybe someone else will come along who knows a little about it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •