Find the answer to your Linux question:
Results 1 to 2 of 2
Running mandrake 9.1. I can start xine, but no audio. when i start xine from CLI i copied this error main: probing <oss> audio output plugin audio_oss_out: Opening audio device... ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Posts
    1

    XINE no audio ..blues


    Running mandrake 9.1. I can start xine, but no audio.

    when i start xine from CLI i copied this error

    main: probing <oss> audio output plugin
    audio_oss_out: Opening audio device...
    audio_oss_out: using device >/dev/dsp<
    audio_oss_out: opening audio device /dev/dsp failed:
    Resource temporarily unavailable
    load_plugins: failed to load audio output plugin <oss>
    main: audio driver probing failed => no audio output

    I am new to linux, so I am looking for what to do next. Not a programmer,,,,not a guru.

    Hope i gave enough information for someone to help me.
    thanks in advance

    -rydogg :o

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I'm suspecting that you're using an older or lower-end soundcard, right? Resource temporarily unavailable means that some other process is holding the soundcard open for the moment, and if you're using a non-multiplexing sound card, only one process can do that at a time.
    I'm guessing that you have either GNOME or KDE started and that therefore either esd or artsd is holding it open. I haven't used Xine myself, but check if there's an option to make the sound go through either esd or artsd, whichever you're using (esd for GNOME, artsd for KDE). That will decrease the quality of sound, but except killing your sound multiplexer everytime you want to watch a movie, I don't know what else to do, really.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •