I keep Firefox 3.6.15 because some extensions do not work with Firefox 4. But 3.6.15 becomes incompatible with time, i.e. it does not start with Hunspell 1.3 . Maybe somebody already took the work of supporting of 3.* version?