Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all, after following this guide for setting up an SFTP server on debian, all the way down through step 3, though I did not "Match Group" I did Match ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    80

    SFTP connetcion exitcode 141


    Hello all, after following this guide for setting up an SFTP server on debian, all the way down through step 3, though I did not "Match Group" I did Match User as I only need 1 user to have access to the SFTP server(did not continue on to step 4 and beyond as they did not apply to me) Im getting the error:

    connection closed by server with exitcode 141

    I get this when trying to log in via filezilla. I actually only got the 141 error on the first attempt, any attempts after that just says "could not connect to server". Username and password authentication goes through, so it is not a login info issue.

    Im running Debian squeeze, and that guide was for Lenny, that shouldnt matter, I dont think.

  2. #2
    Just Joined!
    Join Date
    Jan 2010
    Posts
    80
    In addition, I cant ssh to the server using the user i made "sftp" though I can ssh to the server with the user name I made on debian install. When attempting to ssh to the server with user "sftp" i get: /bin/bash: No such file or directory.

    I can also connect via sftp via filezilla on the user name made at debian install.


    I hope this helps.

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    80
    Problem solved. After reading this: Chroot in OpenSSH I fixed it.

    I userdel -f sftp
    adduser sftp

    then added this to the /etc/ssh/sshd_config file:

    Match user sftp
    ForceCommand internal-sftp
    ChrootDirectory /home

    I then commented the default subsystem as below, and added the correct one.

    #Subsystem sftp /usr/libexec/sftp-server
    Subsystem sftp internal-sftp

    And it worked, my sftp user is not rooted to its home dir on filezilla.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •