Find the answer to your Linux question:
Results 1 to 10 of 10
I'm using the Kaffeine Media Player to play a music video (.mov) I see the video, but I'm not getting any sound....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    DFX
    DFX is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    45

    No sound


    I'm using the Kaffeine Media Player to play a music video (.mov)

    I see the video, but I'm not getting any sound.

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    Kaffeine itself isn't a media player, it's a frontend for Xine. You probably don't have the right codecs installed for sound, you can get pretty much any codec you need from here.
    I don't know where you put the codec files with Xine, as I use MPlayer, but there's probably a codec folder somewhere to extract them to.
    Emotions are the key to the soul.
    Registered Linux User #375050

  3. #3
    DFX
    DFX is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    45
    So I need a different codec to play sound on movies than I need to play audio files?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    Maybe. The movie file you're trying to play appears to be Quicktime format (.mov) and Quicktime has it's own set of codecs for video and audio, so of course the codecs for playing mp3 audio are different from the Quicktime audio codecs. Basically, I'd just get all the codecs and so not have to worry about it.
    Th above is true for all OSes, not just Linux.
    Emotions are the key to the soul.
    Registered Linux User #375050

  6. #5
    Just Joined!
    Join Date
    Dec 2004
    Posts
    17
    Do you get sound from a CD in the same drive? I'm a newbie and found out that you must have an audio cable from you CD/DVD drive to your audio card to get audio in Linux (at least on my installation). I had just built the box myself for Windows, which never needs an audio cable (it reads the audio digitally via the data cable), so I knew that there wasn't one installed. As soon as I hooked up the cable the audio started playing.

  7. #6
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    I almost never play CDs in my computer, as my computer uses the auxillery input on my stereo, so I just play CDs in the stereo or plug my headphones into the CD drive and hit the play button on the CD drive. I always hook up the CD audio cable though, even in windows, because there's a reason for it- to play analog audio.
    Anyways that shouldn't have anything to do with this problem, because that was dealing with an audio cd with raw, uncompressed audio. Audio CDs have a special format. If you're trying to play a Quicktime movie off a CD, it's read as a data disc. The audio and video are heavily compressed requiring special codecs to decompress them. So this shouldn't have anything to do with the audio cable.
    Emotions are the key to the soul.
    Registered Linux User #375050

  8. #7
    DFX
    DFX is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    45
    Quote Originally Posted by Stormblazer
    Kaffeine itself isn't a media player, it's a frontend for Xine. You probably don't have the right codecs installed for sound, you can get pretty much any codec you need from here.
    I don't know where you put the codec files with Xine, as I use MPlayer, but there's probably a codec folder somewhere to extract them to.
    Sorry, I am still new with Linux. How do I install these? or any .tar.gz/.x86.run file for that matter?

  9. #8
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    tar.gz and tar.bz2 are compression formats native to linux.
    Basically, a tar.gz/tar.bz2 are the Linux equivilent of zip files in windows, but more friendly to linux stuff, such as file permissions.
    For programs, this typically means you have the source code, so you'll need to extract, compile, and install it like this:
    Code:
    tar -xvzf [i]file[/i]
    cd [i]folder_you_extacted_to[/i]
    ./compile
    make
    make install
    Note you need to be root to "make install"
    Most applications use this method, and you can see compile options by entering "./configure --help" if you need to. For example, if you want GUI support in MPlayer and you're compiling from source, you'll need to run "./configure --enable-gui" instead of "./configure"
    You'll also need the developer tools/libraries from your distro disks.

    As for the codecs package on MPlayer's website, it's just a compressed file containing the most common codecs that aren't opensource (such as windows media, quicktime, and realmedia). If you're using MPlayer from RPMs, you can place the codecs in /usr/share/mplayer/codecs or /usr/share/codecs. If you're using MPlayer from source, put them in /usr/local/share/codecs after install, or you can put them anywhere before you install and set the location with the compile-time options.
    If you're using Xine, I have no idea where those codecs need to go, you could try /usr/share/codecs. Your best bet is to search for an already existing folder named "codecs" and extract them into there.
    Emotions are the key to the soul.
    Registered Linux User #375050

  10. #9
    DFX
    DFX is offline
    Just Joined!
    Join Date
    Dec 2004
    Posts
    45
    When I run the ./configure i get this...

    configure: error: no acceptable C compiler found in $PATH


    also, how would I install a .x86.run?

    sorry for my ignorance.

  11. #10
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    the error means you'll need to install all the development tools and headers, which should be available on the discs you installed Linux from. There's a lot of them, so I reccomend using whatever program your distro uses for installing software from those discs.
    Fedora Core has a utility in the menu for "Add/Remove Programs..." that works great, I don't know about other distros.

    as for .x86.run , I'm not sure, but I'm guessing it's an executable file, so try going to the directory it's in in the terminal, and entering the name of the .x86.run file with "./" in front of it.
    Emotions are the key to the soul.
    Registered Linux User #375050

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •