Find the answer to your Linux question:
Results 1 to 2 of 2
Let me start with I'm still new to Linux, so be gentle. I'm trying to install an application that has unmet dependencies, specifically it can't find Python 2.7. I'm using ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011
    Posts
    1

    unmet dependencies


    Let me start with I'm still new to Linux, so be gentle.

    I'm trying to install an application that has unmet dependencies, specifically it can't find Python 2.7. I'm using Ubuntu 10.04 which uses 2.6.5 in its repositories. I understand that replacing it can cause some issues, so I've created an install using the following code

    tar xzf Python-2.7.tgz
    cd Python-2.7
    ./configure
    make
    sudo make altinstall

    the error when I try to install is as follows

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help resolve the situation:

    The following packages have unmet dependencies:
    contourconfig: Depends: python (>= 2.7) but 2.6.5-0ubuntu1 is to be installed
    Depends: python-gobject-2 but it is not installable
    E: Broken packages


    My question is how can I get my package to install and use this version of python? Please note that most of what I have do so far is a collaboration of Google and trial and error, so explanations of why you ask me to do something would be appreciated so I can see why I'm doing something, not just typing in what someone writes down.

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hello there!

    Ubuntu 10.04 has up to Python 2.6.5 in it's default repos.
    If running all system updates have not resolved dependencies, then you have two options.
    1. Resolve all dependencies on your own, outside of the package manager. This could lead to it's own issues.
    2. Update to a newer version of Ubuntu.



    Ubuntu 11.04 has Python 2.7.1 ready to go.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •