Find the answer to your Linux question:
Results 1 to 3 of 3
Hey guys, so yesterday I installed Fedora 16 and succefully compiled FOX 1.6 library and then XFE 1.32.4. First problem: xfe could not have find libFOX-1.6.so.0 , so I added ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2012
    Posts
    2

    XFE is not displaying icons


    Hey guys,
    so yesterday I installed Fedora 16 and succefully compiled FOX 1.6 library and then XFE 1.32.4. First problem: xfe could not have find libFOX-1.6.so.0 , so I added path /usr/local/lib where my FOX library was located to /etc/ld.so.config. Now I can start xfe, the problem is that there are no icons. Well just look at the attachment. I tried change icon theme but didn't work, also i checked - and yes, there are .png files in theme directories. Is there something I could have done possibly wrong, or should I report this as bug ?

    Thanks
    Attached Images Attached Images

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,452
    Well, you need to add /usr/local/lib to your LD_LIBRARY_PATH environment in either your ~/.bash_profile, or in /etc/profile, or alternatively you need to configure the FOX library installation prefix to /usr instead of the default /usr/local.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jan 2012
    Posts
    2
    Ok well I am not sure if this si really problem. As I mentioned, I already added path /usr/local/bin - I created file mylib.conf in /etc/ld.so.conf.d/ which contains /usr/local/bin - isn't that enought ? However, as you said, i tried export LD_LIBRARY_PATH=/usr/local/lib:${LD_LIBRARY_PATH} but xfe still starts with all those small 'PNG' icons just like before.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •