Find the answer to your Linux question:
Results 1 to 2 of 2
Hi everyone, I'm trying to build and install an application (called "cdec") Following the instructions I first call autoreconf -ifv and then ./configure --disable-gtest So far no error but when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    1

    Libtool error during make


    Hi everyone,

    I'm trying to build and install an application (called "cdec")

    Following the instructions I first call

    autoreconf -ifv
    and then

    ./configure --disable-gtest
    So far no error but when i call

    make
    I get the following error:

    Making all in dpmert
    make[2]: Entering directory `/home/ccadmin/Documents/SMT/redpony-cdec-d4c89a1/dpmert'
    /bin/sh ../libtool --tag=CC --mode=link gcc -g -O2 -all-static -pthread -L/usr/local/lib -R/usr/local/lib -o sentserver sentserver.o -lboost_program_options-mt
    libtool: link: gcc -g -O2 -static -pthread -o sentserver sentserver.o -L/usr/local/lib -lboost_program_options-mt -pthread -Wl,-rpath -Wl,/usr/local/lib
    /usr/lib/gcc/i586-suse-linux/4.5/../../../../i586-suse-linux/bin/ld: cannot find -lboost_program_options-mt
    collect2: ld returned 1 exit status
    make[2]: *** [sentserver] Error 1
    make[2]: Leaving directory `/home/ccadmin/Documents/SMT/redpony-cdec-d4c89a1/dpmert'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/ccadmin/Documents/SMT/redpony-cdec-d4c89a1'
    make: *** [all] Error 2
    I've searched with google and read around abit but couldn't really find a solution.
    One site suggested that the -pthread library wasn't configured right and said to add "-pthread) continue;;" before "esac # case $deplib" in the file /usr/share/libtool/ltmain.sh but this didn't change anything.

    Any help would be greatly appreciated.

    Thanks for your time,
    ~Caerynlae

  2. #2
    Just Joined!
    Join Date
    Mar 2012
    Posts
    18
    Which distro are you using? In Fedora you can install an package that sounds similar to yours (libmpcdec) directly via yum...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •