Find the answer to your Linux question:
Results 1 to 3 of 3
On my new-laid mint linux 12 "Lisa" I've installed tshark by simply typing "sudo apt-get install tshark". In my opinion this should be self-explaining: kutacz-Desktop tomek # tshark -v tshark: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2012
    Posts
    2

    Tshark local capture problem


    On my new-laid mint linux 12 "Lisa" I've installed tshark by simply typing "sudo apt-get install tshark".

    In my opinion this should be self-explaining:
    kutacz-Desktop tomek # tshark -v
    tshark: Lua: Error during loading:
    [string "/usr/share/wireshark/init.lua"]:45: dofile has been disabled
    TShark 1.6.2

    Copyright 1998-2011 Gerald Combs <geraldatwireshark.org> and contributors.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    Compiled (64-bit) with GLib 2.29.92, with libpcap 1.1.1, with libz 1.2.3.4, with
    POSIX capabilities (Linux), without libpcre, with SMI 0.4.8, with c-ares 1.7.4,
    with Lua 5.1, without Python, with GnuTLS 2.10.5, with Gcrypt 1.5.0, with MIT
    Kerberos, with GeoIP.

    Running on Linux 3.0.0-12-generic, with libpcap version 1.1.1, with libz
    1.2.3.4.

    Built using gcc 4.6.1.
    How to enable dotted files? Or is there other reason?

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,759
    Google is your friend: tshark AND "45: dofile has been disabled"

    You're running tshark as root and this is an expected message:

    Code:
    [string "/usr/share/wireshark/init.lua"]:45: dofile has been disabled

  3. #3
    Just Joined!
    Join Date
    Mar 2012
    Posts
    2
    tomek@tomek-Desktop ~ $ sudo tshark -f "udp port 1812" -i eth0 -w /tmp/capture.cap
    [sudo] password for tomek:
    tshark: Lua: Error during loading:
    [string "/usr/share/wireshark/init.lua"]:45: dofile has been disabled
    Running as user "root" and group "root". This could be dangerous.
    Capturing on eth0
    This was with "sudo". Why it doesn't capute any frames?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •