Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
Yesterday I did try ./configure --with-crt-dir=/usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)/ No dice......
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined! bonesTdog's Avatar
    Join Date
    Jan 2011
    Location
    Atlanta, GA
    Posts
    91

    Yesterday I did try ./configure --with-crt-dir=/usr/lib/$(shell dpkg-architecture -qDEB_HOST_MULTIARCH)/

    No dice...

  2. #12
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,488
    So this is what I did to compile emacs from source. This is on Linux Mint 12.

    After a successful download, I cd'd into the emacs directory and ran
    Code:
    ./configure
    . I got the following error
    Code:
     configure: error: crt*.o not found.  Use --with-crt-dir to specify the location.
    I had a look to see where (or if) these files could be found by running
    Code:
    sudo find / -name "crt*.o"
    which in my case returned
    Code:
    /usr/lib/x86_64-linux-gnu/crt1.o
    /usr/lib/x86_64-linux-gnu/crti.o
    /usr/lib/x86_64-linux-gnu/crtn.o
    /usr/lib/fpc/2.4.4/units/x86_64-linux/rtl/crt.o
    /usr/lib/gcc/x86_64-linux-gnu/4.6/crtbeginT.o
    /usr/lib/gcc/x86_64-linux-gnu/4.6/crtfastmath.o
    /usr/lib/gcc/x86_64-linux-gnu/4.6/crtbeginS.o
    /usr/lib/gcc/x86_64-linux-gnu/4.6/crtprec32.o
    /usr/lib/gcc/x86_64-linux-gnu/4.6/crtprec64.o
    /usr/lib/gcc/x86_64-linux-gnu/4.6/crtendS.o
    /usr/lib/gcc/x86_64-linux-gnu/4.6/crtbegin.o
    /usr/lib/gcc/x86_64-linux-gnu/4.6/crtend.o
    /usr/lib/gcc/x86_64-linux-gnu/4.6/crtprec80.o
    I then ran
    Code:
    ./configure --with-crt-dir=/usr/lib/x86_64-linux-gnu
    and got the following errors
    Code:
    configure: error: The following required libraries were not found:
        libXpm libjpeg libgif/libungif libtiff
    Maybe some development libraries/packages are missing?
    If you don't want to link with them give
        --with-xpm=no --with-jpeg=no --with-gif=no --with-tiff=no
    as options to configure
    I installed the missing libraries using
    Code:
    sudo apt-get install libtiff4-dev libjpeg-dev libgif-dev libxpm-dev
    and re-ran the previous
    Code:
    /configure --with-crt-dir=/usr/lib/x86_64-linux-gnu
    . This time it completed successfully so I ran
    Code:
    make
    which took quite a while.

    There appeared to be no errors so I ran
    Code:
    sudo make install
    et voila! one compiled emacs.

    The upshot is that the patch is only required when using the Debian source. Talking of patch, I'll put together a brief intro and post here.

    Also, while deleting and re-extracting will work, you should also be able to use
    Code:
    make clean
    to reset the environment. If you hold onto the extracted source you can run
    Code:
    sudo make uninstall
    if you ever want to get rid of it.
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  3. #13
    Just Joined! bonesTdog's Avatar
    Join Date
    Jan 2011
    Location
    Atlanta, GA
    Posts
    91
    Well, I finally got a chance to sit and play with this for a while. I never received any errors when I ran ./configure, but I followed some of of your following instructions to point it to the right directory for the crt file just to make sure. I also made sure I had headers installed but received the same error when I ran make and it bombed out with error 2. I don't want to let this thing beat me, but not sure what else to try.

    Open for any suggestions. This is supposed to be the "warmup" to prepare for Linux From Scratch and I am concerned I can't master the warmup...

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •