Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I have been trying to install Zabbix on a server to monitor quite a few servers. I have the agent installed just fine on everything else, however the server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2011
    Posts
    10

    Installing zabbix server - dependency issues!


    Hello, I have been trying to install Zabbix on a server to monitor quite a few servers. I have the agent installed just fine on everything else, however the server install has been a nightmare.

    FTR, we use RHEL forgot the exact version.....

    To use the web interface for zabbix 1.8.x (no earlier version will be acceptable here so I've been told), it requires libcurl, version >= 7.13.1. However installing curl through the yum installer only goes up to 7.12.1.

    I tried downloading an rpm for it of newer version of libcurl, and zabbix does not find it in the config. It seems when passing the parameters to the config script, you have to send it to the curl-config for some reason like --with-libcurl=/usr/bin/curl-config and then it has issues finding the libraries in /usr/lib, even though they might be there.

    I have even tried downloading and compiling the curl source, and pointing to where I installed that, but nothing has worked so far. Any ideas?

  2. #2
    Just Joined!
    Join Date
    May 2012
    Posts
    9
    Hi
    You try with automated script to install zabbix 1.8

  3. #3
    Just Joined!
    Join Date
    Apr 2011
    Posts
    10
    Automated script? Where?

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Based upon your version of curl (7.12.1) i am guessing you are using RHEL 4.x - you can verify with this command:
    Code:
    cat /etc/redhat-release
    anyway, i have a RHEL 4.x system, and i was able to compile curl (latest version - 7.25.0) and then pass the location of it to zabbix (version 1.8.13) and compile zabbix successfully, e.g.:

    Code:
    ./configure --with-libcurl=/opt/curl/bin/curl-config
    i must not be doing something that you are doing. can you post your actual commands that you're using to compile, plus the exact error messages you are getting?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •