Find the answer to your Linux question:
Results 1 to 7 of 7
Hi All I have Nagios installed on a server with a number of ubuntu servers running NRPE. I have a few different scripts running with no issues except for 1 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    9

    Nagios Issue


    Hi All

    I have Nagios installed on a server with a number of ubuntu servers running NRPE. I have a few different scripts running with no issues except for 1 that needs to check mysql replication on the slave machine.

    If I run the file directly on the host machine
    /usr/local/nagios/libexec/check-mysql-slave.pl

    I get the correct responce
    OK - Waiting for master to send event, replicating host xx.xx.xx.xx:3306

    When I run this using the NRPE check
    /usr/local/nagios/libexec/check_nrpe -H localhost -c check-mysql-replication

    I get NRPE: Unable to read output

    I have the users on the file set as nagios as I should and I have the file set with the correct permissions

    Can anyone shed anylight here on what I am doing wrong

    Thanks

  2. #2
    Just Joined!
    Join Date
    Dec 2010
    Posts
    13
    Hi Glennbtn,
    Check if the port 5666 is open in your localhost. You can check this way netstat -at |grep nrpe.

    --Regards,
    Sumit.

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    9
    Thanks for a reply Sumit

    Yes I have configured port 5666. I have other scripts checking memory etc which are all working fine, it's just this 1 script that when run with nrpe does not work.

    Thanks

    Glenn

  4. #4
    Just Joined!
    Join Date
    Dec 2010
    Posts
    13
    Hi Glennbtn,
    If you are not running the command from root then please try to run it as
    sudo /usr/local/nagios/libexec/check_nrpe -H localhost -c check-mysql-replication

    --Regards,
    Sumit.

  5. #5
    Just Joined!
    Join Date
    Mar 2010
    Posts
    9
    HI Sumit and thanks for the responce

    I still get the same answer NRPE: Unable to read output

  6. #6
    Just Joined!
    Join Date
    Dec 2010
    Posts
    13
    Hi Glenn,
    Please let me know how did you ran the command. I mean are you running it from root or you are running it as sudo user. Also try to run the command a the root user.

    --Regards,
    Sumit.

  7. #7
    Just Joined!
    Join Date
    Mar 2010
    Posts
    9
    I ran the command as both root and the nagios users. Both give the same NRPE result

    Both will run the manual .pl script file with the correct results

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •