Find the answer to your Linux question:
Results 1 to 5 of 5
Hi Everyone, I am now having a urgent problem when I install a program named "tRNAscan-SE", a bioinformatics package, in Ubuntu. According to the installation manual, I need to type ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Posts
    2

    Error while doing Make


    Hi Everyone,

    I am now having a urgent problem when I install a program named "tRNAscan-SE", a bioinformatics package, in Ubuntu. According to the installation manual, I need to type "make", "make install" and "make testrun" sequentially. I met the trouble in the 3rd step.

    Here is the situation:

    snapshot1.jpg

    Selection_001.jpg

    snapshot3.jpg
    snapshot4.jpg

    It shows that the tRNAscan-SE has not been installed correctly. I have searched a lot online but nothing works. Anyone here can give me an idea?

    Thanks very much.

  2. #2
    Linux Newbie
    Join Date
    Jun 2012
    Location
    SF Bay area
    Posts
    196
    xidchen there's not much information in the screen captures you posted. The first three appear to have worked without any error to compile and install the software and manuals. And the fourth one just indicates that the test run tried to compare expected results to what it got when run on your system and the two results were not the same. So that's pretty much all I can tell from what you posted. The results from running the software on your system (after it was compiled and installed) didn't match the sample test results shipped with the package. Someone would have to look at the way the Makefile is running the "testrun" to figure out more. It appears designed to try and be clean/simple in what it displays, which is commendable. But that means it's not possible to see what it's doing underneath that's causing it believe there's an error.

  3. #3
    Linux User
    Join Date
    Nov 2008
    Location
    Tokyo, Japan
    Posts
    260
    As @cnamejj mentioned, it seems to have built correctly. Did you also run the "make install" command?

    If so, the program is now somewhere in your system, most likely the "/usr/local/bin" directory which is the place for locally compiled software to be installed (software you compiled on your own computer). Execute this command:
    Code:
    find /usr/local/bin -iname '*rna*scan*'
    You may get a few matching programs, you may get only one. If you see a program named "/usr/local/bin/tRNAscan-SE" or something similar, then you should be able to execute it by just typing the whole name (including "/usr/loca/bin") and pressing enter, for example "/usr/local/bin/tRNAscan-SE" should work.

    You should also check your PATH setting. Try this command:
    Code:
    echo $PATH | sed -e 's,:,\n,g'
    If the output of this commands contains "/usr/local/bin", it means you can run the tRNAscan-SE program by typing in just "tRNAscan-SE" on the command line and pressing enter. If you don't see "/usr/local/bin", you should need to do a bit more work to make your system run programs that were compiled locally on your machine, i.e. programs installed into the "/usr/local/bin" directory. Ask us how if you want to know.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2007
    Posts
    3
    Looks like you did the installation however your test is failing because the command echo is not part of /bin/sh which is used by make by default, you need to run 'SHELL=/bin/bash;export SHELL' and try the 'make testrun' again

  6. #5
    Just Joined!
    Join Date
    Jul 2012
    Posts
    2
    Thanks @cnamejj, @ramin.honary, @REDjinnee. It's not a problem any more. Because I find that the error in 'make testrun' doesn't affect the normal running of the program "tRNAscan-SE". I don't need to care about the error.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •