Find the answer to your Linux question:
Results 1 to 5 of 5
I have just installed Mint 13 host os, and installed xp pro in virtualbox to run netflix. I connect to the net through a wireless atheros card. Searching forums, people ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    10

    virtualbox xp guest, no internet


    I have just installed Mint 13 host os, and installed xp pro in virtualbox to run netflix.

    I connect to the net through a wireless atheros card.

    Searching forums, people say to change to bridged in vbox's network settings. I have tried all the options in vbox's network; NAT, bridged, Internal, Host-only, unchecking the cable connected box; still nothing.

    Bridged gives me the connected but limited or no connectivity bubble, with zero connectivity.

    Really really stumped, please help!

  2. #2
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    889
    Windows isn't as flexible as linux. Set the adapter type to bridge, and then install windows.
    If you're running NAT, you have to make sure forwarding is enabled on the host os.

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    10
    I enabled forwarding, restarted xp and selected nat but nada.

    Will attempt another install ready set as bridge, fingers crossed.

    In another forum, someone suggested:

    "This could be a DHCP issue with the Windows OS. Check the event viewer inside of your XP guest to see what it is reporting, if it's something related to DHCP try assigning a static IP for it inside of your router. This has come up before in a similar setup a friend of mine had where the XP system was not leasing the IPs correctly through DHCP inside of the guest."

    I'm not sure what to do. I mean, assign a static IP for what? My router sees my computer, not vbox inside it. What am I missing?

    xp says "the problem occurred because the network did not assign a network address to the computer"

    and someone else said in an old thread to use NAT and manually resolve the ip address to 10.0.2.2. How and where do you resolve the ip address?

    Ultra confused. Thanks in advance

  4. #4
    Just Joined!
    Join Date
    Mar 2010
    Posts
    10
    Note: I brought the suggestion here as the person didn't get back yet

  5. #5
    Just Joined!
    Join Date
    Mar 2010
    Posts
    10
    ok, I blundered through, added in my router the mac address and assigned a static ip address to it, chose bridged and eth0, with PC-net FAST III and it works!

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •