Find the answer to your Linux question:
Results 1 to 2 of 2
I am trying to install and test a program called TranscriberAG on Linux Mint 13 w/xfce 32-bit. The website for the program is: TranscriberAG The web page for the installation ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2012
    Posts
    24

    TranscriberAG on Linux Mint 13


    I am trying to install and test a program called TranscriberAG on Linux Mint 13 w/xfce 32-bit.

    The website for the program is:
    TranscriberAG

    The web page for the installation is:
    TranscriberAG

    The Dependencies listed are:

    Gtk+ Cross-platform graphical toolkit (C library)
    Gtkmm C++ wrapper for GTK
    FFmpeg Audio/video encoding/decoding framework (C library)
    Libsndfile Audio read/write (C library)
    Xerces XML Handling library
    Aspell Spell Checker
    LibCurl File transfers libraries
    I am currently trying to install all the dependencies starting with Gtk+.

    I googled Gtk+
    downloaded the package from:
    GTK+ Download: GNU/Linux

    I extracted gtk+-3.4.0.tar.xz in the downloads folder.

    I entered the gtk+-3.4.0 from the root.

    ./configure

    configure: error: Package requirements (glib-2.0 >= 2.31.20 atk >= 2.1.5 pango >= 1.29.0 cairo >= 1.10.0 cairo-gobject >= 1.10.0 gdk-pixbuf-2.0 >= 2.25.2) were not met:

    No package 'glib-2.0' found
    No package 'atk' found
    No package 'pango' found
    No package 'cairo' found
    No package 'cairo-gobject' found
    No package 'gdk-pixbuf-2.0' found
    I installed the first dependency glib-2.0 and upgraded.

    I attempted to install the second dependency atk with ./configure

    checking for GLIB - version >= 2.31.2...
    *** 'pkg-config --modversion glib-2.0' returned 2.33.8, but GLIB (2.32.3)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    configure: error:
    *** GLIB 2.31.2 or better is required. The latest version of
    *** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
    *** but not in the same location as pkg-config add the location of the file
    *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
    I do not know how to set the environment variables.

    Any help?

  2. #2
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225
    Installing gtk+ is not trivial. Five different source packages have to be installed in order (gtk+ is installed last). You can get general installation instructions by following the "installation guide" link on this page: GTK+ Download: GNU/Linux. More specific instructions are at this forum thread: http://www.linuxforums.org/forum/ubu...tml#post897799

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •