Find the answer to your Linux question:
Results 1 to 1 of 1
I was previously able to run cups 1.6 in Arch without problems. The version I have now is cups 1.6.1-6 (installed a week ago) and it says "Printer not connected; ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,222

    [Solved] Cups 1.6.1 in Arch wrongly says my printer is not connected


    I was previously able to run cups 1.6 in Arch without problems. The version I have now is cups 1.6.1-6 (installed a week ago) and it says "Printer not connected; will retry in 30 seconds." Jobs stay in the queue and are not printed.

    To check if there really was a physical connection problem, I rebooted into my other distro, which is based on Slackware and uses cups-1.4.6. When I tried from there, I could print without difficulty.

    I am attaching a cups error log which was made in Arch with the reporting level set to "debug". Perhaps someone can tell from it what is going wrong.

    [Edit] Forget it! I did something stupid as usual. I had edited the systemd cups.service file in /usr/lib to add an ExecPre command "/sbin/modprobe lp". But I forgot that these files get overwritten during updates and therefore should not be edited. So of course the new virgin file that came over with last week's update did not contain that command and my lp0 port was not working.

    I have now copied the file to /etc/systemd/system and edited it there. Grrrr!
    Attached Files Attached Files
    Last edited by hazel; 09-14-2012 at 07:01 PM. Reason: Problem solved!
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •