Find the answer to your Linux question:
Results 1 to 6 of 6
Hi all, Ubuntu 12.04 desktop 64bit I followed; 1) How To Install LAMP Server in Ubuntu Server 12.04 LTS How To Install LAMP Server in Ubuntu Server 12.04 LTS | ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814

    about installing wordpress


    Hi all,

    Ubuntu 12.04 desktop 64bit

    I followed;

    1)
    How To Install LAMP Server in Ubuntu Server 12.04 LTS
    How To Install LAMP Server in Ubuntu Server 12.04 LTS | Ubuntu Server Guide

    2)
    How to install WordPress in Ubuntu Server 12.04 LTS Precise Pangolin
    How To Install Latest Wordpress in Ubuntu Server 12.04 LTS | Ubuntu Server Guide

    On running;
    $ sudo bash /usr/share/doc/wordpress/examples/setup-mysql -n wordpress_preciseserver blog.preciseserver.com
    ping: unknown host blog.preciseserver.com

    Please advise how to fix this problem? TIA

    Regards
    satimis

  2. #2
    Just Joined! msohail's Avatar
    Join Date
    Nov 2011
    Posts
    47
    Edit /etc/hosts file with the IP address to point to blog.preciseserver.com
    Add the same to your DNS records for everyone to access or if you the only one then add the add same as /etc/hosts file in your windows hosts file as well.

    Jazak Allah,
    Sohail

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    Quote Originally Posted by msohail View Post
    Edit /etc/hosts file with the IP address to point to blog.preciseserver.com
    Hi,

    $ nslookup blog.preciseserver.com
    Code:
    Server:         127.0.0.1
    Address:        127.0.0.1#53
    
    ** server can't find blog.preciseserver.com: NXDOMAIN
    $ cat /etc/hosts
    Code:
    127.0.0.1       localhost
    127.0.1.1       localhost.localdomain   localhost
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    Replace the line
    Code:
    127.0.0.1       localhost
    with;
    Code:
    127.0.0.1       blog.preciseserver.com
    $ ping -c 2 blog.preciseserver.com
    Code:
    PING blog.preciseserver.com (127.0.0.1) 56(84) bytes of data.
    64 bytes from blog.preciseserver.com (127.0.0.1): icmp_req=1 ttl=64 time=0.036 ms
    64 bytes from blog.preciseserver.com (127.0.0.1): icmp_req=2 ttl=64 time=0.032 ms
    
    --- blog.preciseserver.com ping statistics ---
    2 packets transmitted, 2 received, 0% packet loss, time 1001ms
    rtt min/avg/max/mdev = 0.032/0.034/0.036/0.002 ms
    Then it works. Thanks


    Add the same to your DNS records for everyone to access or if you the only one then add the add same as /etc/hosts file in your windows hosts file as well.
    I don't run DNS server here.

    $ cat /etc/resolv.conf
    Code:
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1

    I found another manual installing wordpress
    WordPress
    https://help.ubuntu.com/community/WordPress

    The steps seems different. I'm not quite clear;
    Code:
    Enable the Universe repository
    1.    I am using Ubuntu server (command line)
    2.    I am using a desktop
    ?

    I'm now installing wordpress on Ubuntu 12.04 desktop

    satimis

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! msohail's Avatar
    Join Date
    Nov 2011
    Posts
    47
    Please add "localhost" besides your blog site address in /etc/hosts file or you may face problems when wordpress tries to communicate with MySQL server if you go with default wordpress installation parameters.

    Jazak Allah,
    Sohail

  6. #5
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    Quote Originally Posted by msohail View Post
    Please add "localhost" besides your blog site address in /etc/hosts file or you may face problems when wordpress tries to communicate with MySQL server if you go with default wordpress installation parameters.
    Whether you meant editing the line as;
    Code:
    127.0.0.1       blog.preciseserver.com    localhost
    Tired it. It also works.

    Please explain why without adding "localhost" next to "blog.preciseserver.com" wiil face problems when wordpress tries to communicate with MySQL server? Why it can't communicate with MySQL server? TIA

    satimis

  7. #6
    Just Joined! msohail's Avatar
    Join Date
    Nov 2011
    Posts
    47
    Quote Originally Posted by satimis View Post
    Whether you meant editing the line as;
    Code:
    127.0.0.1       blog.preciseserver.com    localhost
    Tired it. It also works.

    Please explain why without adding "localhost" next to "blog.preciseserver.com" wiil face problems when wordpress tries to communicate with MySQL server? Why it can't communicate with MySQL server? TIA

    satimis
    When you install wordpress from the browser, the browser loads up the default connection details of mysql, and adds servers name as localhost; which in your case will not be able to resolve since you removed the entry from /etc/hosts file (of course u added it now ). Then you will have to put your blog's address in "Server" section, which of course will also work but which is not a good practice when everything is in one single machine.

    Jazak Allah;
    Sohail

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •