Find the answer to your Linux question:
Results 1 to 4 of 4
Hi everybody The splitted zip archive which is made with zip command can not be extracted with ark and can not be opened with 7zip on windows. As i said. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2013
    Posts
    7

    The splitted zip archive files problem


    Hi everybody

    The splitted zip archive which is made with zip command can not be extracted with ark and can not be opened with 7zip on windows.

    As i said. When i have made splited zip archive and try to open with ark, yes it can open it but when i am chosing to extract it is doing nothing.

    And

    When i tring to open that splited zip archive on windows with 7zip. It is giving an error that, " this file cannot be opened as an archive file " and it is stopping.

    With a whole ( not splited ) zip archives there are no problem.

    I am using kubuntu-12.04.1-desktop-i386.

    Could anyone help...
    Last edited by coldblue; 02-05-2013 at 03:01 PM.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hello,

    Is this for going from Linux to Windows? If so, then how about using split in Linux to split your zip file. Then use type to join them together, in Windows?

    e.g., on Linux:
    Code:
    [root@localhost /tmp]# zip files.zip net.bin rpcclient.bin md5sum.txt
      adding: net.bin (deflated 67%)
      adding: rpcclient.bin (deflated 68%)
      adding: md5sum.txt (deflated 14%)
    [root@localhost /tmp]#
    then split:
    Code:
    [root@localhost /tmp]# split -n4 --verbose files.zip
    creating file `xaa'
    creating file `xab'
    creating file `xac'
    creating file `xad'
    [root@localhost /tmp]#
    then copy xaa xab xac and xad to Windows, and on Windows in cmd prompt:
    Code:
    c:\>type xaa xab xac xad > files.zip
    then call 7-zip to unzip it:
    Code:
    c:\7-Zip\7z.exe x files.zip
    
    7-Zip 4.65  Copyright (c) 1999-2009 Igor Pavlov  2009-02-03
    
    Processing archive: files.zip
    
    Extracting  net.bin
    Extracting  rpcclient.bin
    Extracting  md5sum.txt
    
    Everything is Ok
    
    Files: 3
    Size:       16870782
    Compressed: 5453479
    If you are not using Windows, then just use cat instead of type, to join the split files back together.

  3. #3
    Just Joined!
    Join Date
    Feb 2013
    Posts
    7
    Thaks for your reply.

    First of all to split my files when i am archiving i am doing this.

    Code:
    skynet@skynet-VirtualBox:~/šalışma$ ls
    linux  network  ses.txt
    skynet@skynet-VirtualBox:~/šalışma$ zip -s 10m  linux  linux/*.*
      adding: linux/Linux_Command_Line_and_Shell_Scripting_Bible_(2nd_Edition).pdf (deflated 17%)
      adding: linux/linux_egitim_101.pdf (deflated 32%)
      adding: linux/linux_egitim_102.pdf (deflated 27%)
      adding: linux/Linux in a Nutshell, 6th Edition.pdf (deflated 48%)                                                                                                                             
      adding: linux/Oreilly.Linux.Network.Administrators.Guide.3rd.Edition.Feb.2005.pdf (deflated 28%)
      adding: linux/OReilly.Linux.System.Administration.Mar.2007.pdf (deflated 23%)
    skynet@skynet-VirtualBox:~/šalışma$ ls
    linux  linux.z01  linux.z02  linux.zip  network  ses.txt
    skynet@skynet-VirtualBox:~/šalışma$
    when i am try to extract linux.z01 linux.z02 linux.zip with ark , it is doing nothing. I have found that unzip not supporting to open splitted archive.

    İt is from man unzip

    "Multi-part archives are not yet supported, except in conjunction with zip. (All parts must be concatenated together in order, and then ``zip -F'' (for zip 2.x) or ``zip -FF'' (for
    zip 3.x) must be performed on the concatenated archive in order to ``fix'' it. Also, zip 3.0 and later can combine multi-part (split) archives into a combined single-file archive
    using ``zip -s- inarchive -O outarchive''. See the zip 3 manual page for more information.) This will definitely be corrected in the next major release."

    So if ark using unzip at its background it is normal.

    but

    When i am taking linux.z01 linux.z02 linux.zip to the windows and trying open it with GUİ of 7zip it is giving " this file cannot be opened as an archive file " Eror.
    Also when i am trying at the CLI is giving same error.

    But 7zip has support to split and extract zip archive format.

  4. #4
    Just Joined!
    Join Date
    Feb 2013
    Posts
    7
    I have tried your method. i have made one zip file and i split it four pieces with split command. After i carried this four file to windows. And merged this files to one file as you say. But unfortunately when i am trying to open it with 7zip , again it gives error. And not opening the file.

    Edit: Sorry for my mistake. when i tried again Your method has worked. I think i missed something at first time. But this method okay forme. But to share this files to someone it is not practical. What do you think about my method. what is problem. Is it possible to try on your computer. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •