Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I'm having trouble installing VMWare 3.1.6. I have set the shell to bash before applying a patch. It's the patch-modules_3.4.0.sh patch. I'm getting No protocol specified messages several times. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Posts
    18

    VMWare 3.1.6 on Ubuntu 12.04.1


    Hello,

    I'm having trouble installing VMWare 3.1.6.
    I have set the shell to bash before applying a patch.
    It's the patch-modules_3.4.0.sh patch.
    I'm getting No protocol specified messages several times.
    Anyway when I start VMWare I get the messages that several modules have to be recompiled.

    The (graphical) output is:

    Virtual Machine Monitor OK
    Virtual Network Device OK
    VMWare Blocking Filesystem NOT OK
    Virtual Machine Communication Interface OK
    VMCI Sockets OK

    Then I get the message that compilaton failed, see the log file.
    Here's a part of the log file:

    Feb 12 10:56:08.521: app-3076372160| Trying to find a suitable PBM set for kernel 3.2.0-29-generic-pae.
    Feb 12 10:56:08.522: app-3076372160| Building module vmblock.
    Feb 12 10:56:08.522: app-3076372160| Extracting the sources of the vmblock module.
    Feb 12 10:56:08.565: app-3076372160| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmblock-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-29-generic-pae/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
    Feb 12 10:56:12.640: app-3076372160| Failed to compile module vmblock!

    Please help I need VMWare.

    Thanks in advance.

  2. #2
    Linux Newbie Syndacate's Avatar
    Join Date
    May 2012
    Location
    Hell..no literally, this state is hell..
    Posts
    192
    Quote Originally Posted by vitronix View Post
    Hello,

    I'm having trouble installing VMWare 3.1.6.
    I have set the shell to bash before applying a patch.
    It's the patch-modules_3.4.0.sh patch.
    I'm getting No protocol specified messages several times.
    Anyway when I start VMWare I get the messages that several modules have to be recompiled.

    The (graphical) output is:

    Virtual Machine Monitor OK
    Virtual Network Device OK
    VMWare Blocking Filesystem NOT OK
    Virtual Machine Communication Interface OK
    VMCI Sockets OK

    Then I get the message that compilaton failed, see the log file.
    Here's a part of the log file:

    Feb 12 10:56:08.521: app-3076372160| Trying to find a suitable PBM set for kernel 3.2.0-29-generic-pae.
    Feb 12 10:56:08.522: app-3076372160| Building module vmblock.
    Feb 12 10:56:08.522: app-3076372160| Extracting the sources of the vmblock module.
    Feb 12 10:56:08.565: app-3076372160| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmblock-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-29-generic-pae/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
    Feb 12 10:56:12.640: app-3076372160| Failed to compile module vmblock!

    Please help I need VMWare.

    Thanks in advance.
    I don't know anything about VMWare....BUT.

    Look into the patch regarding compiling on kernel 3.1 and higher. VMWare apparently needs to be patched to do so.

    Instructions are here: Patches for VMwareŽ Workstation 8.0.4 build-744019

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •