Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I recently started a Linux from Scratch project. I completed the main part with minimal errors. I moved on to BLFS and added a user ("developer"), then installed openssl, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2013
    Posts
    2

    LFS/BLFS: "passwd" and "sudo" don't accept input.


    Hi,

    I recently started a Linux from Scratch project. I completed the main part with minimal errors. I moved on to BLFS and added a user ("developer"), then installed openssl, wget, and sudo. I added my user via "visudo", and then tested it. I got a segfault. Then, I realized my new user didn't have a password, so I switched to the root account and ran "passwd developer". This went by my screen:
    Code:
    Changing password for developer
    Enter the new password (minimum of 5 characters)
    Please use a combination of upper and lower case letters and numbers.
    Bad password: too short.  
    Warning: weak password (enter it again to use it anyway).
    passwd: password changed.
    And it didn't let me input ANYTHING. I tried piping with
    Code:
    echo -e "somepassword\nsomepassword" | passwd developer
    No luck. Just in case, I ran sudo another time and this happened:
    Code:
    Sorry, try again.
    Sorry, try again.
    Sorry, try again.
    sudo: 3 incorrect password attempts
    No input, just like passwd. So, I'm assuming there's something wrong with my password input areas. Im running this in a chroot environment via Ubuntu 12.10.

  2. #2
    Linux User jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    257
    I'm afraid you will have to show some of your input coding routines to get help like this. Since you wrote the code (correct?) you need to show the code to get help with this type of problem and I don't know if this is the proper place, as I'm just learning where things are here. If I'm confused so are others, so maybe you need to clarify what you are doing and how you are invoking it if it's Linux code you're running.

    Jack

  3. #3
    Just Joined!
    Join Date
    Feb 2013
    Posts
    2
    Actually, I didn't write sudo or passwd. They are just packages I compiled. If you are looking for configure flags:
    Sudo:
    Code:
    ./configure --prefix=/usr                   \
                --libexecdir=/usr/lib/sudo      \
                --docdir=/usr/share/doc/sudo-1.8.6p3 \
                --with-all-insults              \
                --with-env-editor               \
                --without-pam                   \
                --without-sendmail
    And I don't remember what I did for passwd's package. I just followed the directions from the book.
    Once again, here are the commands I ran:

    (as root)
    Code:
    passwd developer
    (as "developer")
    Code:
    sudo -i

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •