Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I have numerous SD memory cards. These have been formatted on a Windows Vista machine originally with no problems (other than all uppercase labels!) I have also formatted them ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    197

    Format of SD memory fails


    Hello,

    I have numerous SD memory cards. These have been formatted on a Windows Vista machine originally with no problems (other than all uppercase labels!) I have also formatted them on this hardware while running Windows 8, again, with no problems.

    On this Linux Debian 6.0.6 system when I attempt to do so, I get errors that usually indicate I can not write to the device. The SD devices are in a read/writer that is wired (internally) to an unused USB header. I am able to use the hardware under Windows 8, so I'm confident that the hardware is working.

    When I use Linux "System Tools>Disk Utility" program, on a 4 GB SD card, I can change the name of the label and the format to ext2. When I attempt to actually format the device and apply the changes, it errors out with

    Code:
    Error creating file system: helper exited with exit code 1: 5738: error writing 131072 bytes: Operation not permitted
    If I go to the top of the GUI, I can attempt to format for a "Master Boot Record" type. When I attempt it, I get

    Code:
    Error creating partition table: helper exited with exit code 1: cannot open /dev/sdd: Read-only file system
    I've checked the write protect and it is where I formatted it on a Windows machine. Any ideas?

    When I try the same operation on a 32 G USB stick. At completion it shows a partition type of "W95 FAT32 (LBA) (0x0c)" is this correct for Linux?


    Please remember that I've been trying this for a while and just can't get it to work no matter what program I use to do it. I've tried gparted and fdisk also with similar results. It always seems to say I can't write to the device. I did remember to un mount the device, but have tried it both ways with the same type results (although it usually says it's mounted).

    Thanks for all the help, I'm expecting!!!

    Jack

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hello

    I've always had much better results formatting devices using gparted under a liveCD such as the Parted Magic LiveCD, or the Gparted LiveCD. If you haven't tried that route, it might be worth testing it to see if you get better results.
    oz

  3. #3
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,007
    file format - Memory stick not formatting? - Ask Ubuntu

    [SOLVED] How to force format a USB device? - Ubuntu Forums

    Though I like Oz keep a gparted and parted magic cd around for stubborn problems. Sometimes I just find it is quicker to just boot a live cd and just get the job done than try and figure out a problem.
    I can then approach the problem later at my leisure. Good luck with it.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  4. #4
    Linux User zenwalker's Avatar
    Join Date
    Feb 2010
    Location
    Inland Empire
    Posts
    292
    SystemRescueCD and what oz said -- for better results!
    "What you think about me is none of my business"
    _______________________________________________
    antiX | SolydX | Puppy Slacko

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •