Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, I have a previous version of os4 on another computer. it's a great OS. when I open a terminal, the very first line has the prompt. just the way ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    49

    remove OS4 terminal greeting, version and copyright


    Hello,

    I have a previous version of os4 on another computer. it's a great OS.
    when I open a terminal, the very first line has the prompt. just the way I like it.
    I installed the latest version on this computer. when I opened up a terminal there was a nice (and unneeded) encouraging message called a 'fortune' and this:


    Welcome to OpenDesktop

    OS4 Release 13 Update 3 (32 bit)

    Copyright (C) 2008, Roberto J. Dohnert


    I removed the 'fortune' after some investigation, but have not found a way to get rid of the rest (seen above). it's nine lines of wasted space every time I open a terminal.

    would somebody please help me remove this?

    I am seriously considering reinstalling the same older version that I have on the other computer.

    thanks.

  2. #2
    Linux User
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    362
    I don't use os4, but...

    /etc/motd or /etc/issue could be the culprits. Otherwise trying grepping around /etc or maybe /usr/share for the word 'Dohnert'. It's pretty unique and unlikely to be found too many places.
    Code:
    cd /etc
    find -follow -name '*' | xargs grep -n "Dohnert" 2>/dev/null
    Also, if you touch $HOME/.hushlogin, it usually shuts up those silly intro messages. At least it's supposed to.

  3. #3
    Just Joined!
    Join Date
    Dec 2008
    Posts
    49
    thanks for the reply.

    a fine person helped me solve the problem here:

    [SOLVED] remove OS4 terminal greeting, version and copyright

    I believe that by opening a terminal, becoming sudo, then:
    gedit bash.bashrc
    commenting out (put a # in front of the line, for newbies) these lines at the bottom of the file:

    cat /etc/shell
    fortune
    cat /etc/blank

    would have solved my problem.

    please excuse my disorganized way of providing the info. I was receiving help and learning as I went along. here is more info from the thread.



    how I got rid of the 'fortune'. I put a # in front of the word fortune in the /etc/bash.bashrc file. I show the bash.bashrc below:



    # System-wide .bashrc file for interactive bash(1) shells.

    # To enable the settings / commands in this file for login shells as well,
    # this file has to be sourced in /etc/profile.

    # If not running interactively, don't do anything
    [ -z "$PS1" ] && return

    # check the window size after each command and, if necessary,
    # update the values of LINES and COLUMNS.
    shopt -s checkwinsize

    # set variable identifying the chroot you work in (used in the prompt below)
    if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
    fi

    # set a fancy prompt (non-color, overwrite the one in /etc/profile)
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '

    # Commented out, don't overwrite xterm -T "title" -n "icontitle" by default.
    # If this is an xterm set the title to user@host:dir
    #case "$TERM" in
    #xterm*|rxvt*)
    # PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD}\007"'
    # ;;
    #*)
    # ;;
    #esac

    # enable bash completion in interactive shells
    #if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    # . /etc/bash_completion
    #fi

    # sudo hint
    if [ ! -e "$HOME/.sudo_as_admin_successful" ] && [ ! -e "$HOME/.hushlogin" ] ; then
    case " $(groups) " in *\ admin\ *)
    if [ -x /usr/bin/sudo ]; then
    cat <<-EOF
    To run a command as administrator (user "root"), use "sudo <command>".
    See "man sudo_root" for details.

    EOF
    fi
    esac
    fi

    # if the command-not-found package is installed, use it
    if [ -x /usr/lib/command-not-found -o -x /usr/share/command-not-found/command-not-found ]; then
    function command_not_found_handle {
    # check because c-n-f could've been removed in the meantime
    if [ -x /usr/lib/command-not-found ]; then
    /usr/bin/python /usr/lib/command-not-found -- "$1"
    return $?
    elif [ -x /usr/share/command-not-found/command-not-found ]; then
    /usr/bin/python /usr/share/command-not-found/command-not-found -- "$1"
    return $?
    else
    printf "%s: command not found\n" "$1" >&2
    return 127
    fi
    }
    fi
    cat /etc/shell
    #fortune
    cat /etc/blank



    I found the file to change. it is /etc/shell

    I went in as sudo and backspaced over the text, making the file blank, then saved and rebooted

    there is no longer any text, however there is three lines of blank space above the prompt at the top.




    If I look at this part:
    Quote:
    cat /etc/shell
    #fortune
    cat /etc/blank
    Then it could be that there are blank lines in /etc/blank.

    You can empty the /etc/blank file or comment out the entry in your /etc/bash.bashrc file (I would prefer the second option).

    You might even want to comment out the whole block (then there's no need to edit /etc/shell and/or /etc/blank.



    I went back as sudo and examined that file/blank page, and noticed I could highlight one line and delete it, then save. so that file provided a sort-of blank line possibly to the terminal only, it appears.



    I just realized what you meant by commenting out lines in bash.bashrc

    put a # in front of
    cat /etc/shell
    cat /etc/blank

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •