Find the answer to your Linux question:
Results 1 to 3 of 3
Suddenly, my firefox refuses to load giving me an error message as follows: Code: XML Parsing Error: undefined entity Location: chrome://browser/content/browser.xul Line Number 290, Column 5: <key id="key_errorConsole" key="&errorConsoleCmd.commandkey;" command="Tools:ErrorConsole" ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    214

    Firefox weirdness


    Suddenly, my firefox refuses to load giving me an error message as follows:

    Code:
    XML Parsing Error: undefined entity
    Location: chrome://browser/content/browser.xul
    Line Number 290, Column 5:    
    
    <key id="key_errorConsole" key="&errorConsoleCmd.commandkey;" command="Tools:ErrorConsole" modifiers="accel,shift"/>
    ----^
    I say suddenly because it was. I was running it fine, then I restarted it and got this error. I have tried a complete re-install and using an omni.ja file from a working system but still get the same result.

    I have also re-installed "xulrunner" to no avail.

    I cannot find "browser.xul" anywhere, even if I unzip omni.ja and all I have found via google and the mozilla forum is to re-install firefox.

    Anybody experienced/fixed this problem? I am at a loss.

    Cheers - VP

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,812
    It seems strange that you should be seeing a chrome error causing firefox problems. It could be anything causing this - it's usually safest to reset your profile when things like this go wrong.

    If you can get firefox loaded but abort the loading of any pages, then you can reset your profile with the Help->Troubleshooting Information menu link, this gives you an option to reset firefox which will probably solve the issue.

    If you cant do that, then you can make the changes by hand. Your profile is stored in your home directory under ~/.mozilla/firefox. Close down firefox then see if you can find your profile in there, you can rename it so that Firefox can't find it when it starts and will give you a clean fresh one. If you can't find your profile, then its safe to just rename the firefox directory itself - again Firefox will re-create it on startup if needed.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    214
    Roxoff.

    Thanks for your response and my apologies for the delay.

    It turns out that firefox has used the term "chrome" since long before the chrome browser was around. It refers to the user interface.

    You can find various lists of the ones used by firefox on the web (Chrome URLs - MozillaZine Knowledge Base for instance).

    I did find one that lets you render an entire firefox in a single tab!

    I had tried everything you suggested, even replaced the file "omni.ja" from a working version but, every time, I got the same error. In desperation, I rebooted my box and the problem went away so I have no idea what triggered it.

    I suspect a lack of heap since the box was being loaded at the time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •