Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, my OS: # uname -a Linux * 2.6.18-348.3.1.el5.028stab106.2 #1 SMP Wed Mar 27 16:56:40 MSK 2013 x86_64 x86_64 x86_64 GNU/Linux Im trying to install gmvault according to this manual ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User postcd's Avatar
    Join Date
    Apr 2011
    Posts
    315

    python-pip at el5


    Hello,

    my OS: # uname -a
    Linux * 2.6.18-348.3.1.el5.028stab106.2 #1 SMP Wed Mar 27 16:56:40 MSK 2013 x86_64 x86_64 x86_64 GNU/Linux

    Im trying to install gmvault according to this manual. and when executed command "pip install virtualenv", it says:
    -bash: pip: command not found

    yum erase python-pip
    shows it is installed:
    python-pip noarch 0.8-1.el5 installed 837 k
    i installed by rpm ivh from https://dl.fedoraproject.org/pub/epe...el5.noarch.rpm
    (from yum was not available)

    please can anyone help me install python-pip, make it working?
    Last edited by postcd; 11-19-2013 at 12:01 PM.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by postcd View Post
    i installed by rpm ivh from https://dl.fedoraproject.org/pub/epe...el5.noarch.rpm
    (from yum was not available)
    you don't want to do that (install RPMS by hand, when they are available in a repo). install the EPEL repo for your distro first, e.g.:

    Code:
    rpm -ivh http://dl.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm
    now you have the epel repo installed.

    now continue with the commands on the site you linked. i noted a couple of typos that will bork it, though: watch out for the single dash starting an option when it should be a double-dash "--", e.g.:

    Code:
    $ virtualenv --no-site-packages gmvault-1.8.1-beta
    $ cd gmvault-1.8.1-beta/bin
    $./pip install --pre gmvault

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •