Find the answer to your Linux question:
Results 1 to 2 of 2
Hi! I was playing with WindowMaker and alltray when alltray crashed and I removed it. I tested to get Arora into the tray but it does'nt work. Late Arora began ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Andy_Crowd's Avatar
    Join Date
    Sep 2013
    Location
    日不落
    Posts
    88

    Question Arora Crash


    Hi!
    I was playing with WindowMaker and alltray when alltray crashed and I removed it. I tested to get Arora into the tray but it does'nt work. Late Arora began to crash... first Youtube videos and sound crashed... but I fixed it with alsamixer somehow... unmuted headphones, strange but worked to play a flash videos. Late I removed flashplugin too. But with no good result. When I start Arora, it might crash or when I close it... I getting errors like:
    Code:
    08cd6000-08cf7000 rw-p 00000000 00:00 0                                  [heap]
    08cf7000-08d18000 rw-p 00000000 00:00 0                                  [heap]
    08d18000-08d39000 rw-p 00000000 00:00 0                                  [heap]
    08d39000-08d5a000 rw-p 00000000 00:00 0                                  [heap]
    08d5a000-08d7b000 rw-p 00000000 00:00 0                                  [heap]
    08d7b000-08d9c000 rw-p 00000000 00:00 0                                  [heap]
    08d9c000-08dbd000 rw-p 00000000 00:00 0                                  [heap]
    08dbd000-08dde000 rw-p 00000000 00:00 0                                  [heap]
    08dde000-08dff000 rw-p 00000000 00:00 0                                  [heap]
    08dff000-08e23000 rw-p 00000000 00:00 0                                  [heap]
    08e23000-08e44000 rw-p 00000000 00:00 0                                  [heap]
    08e44000-08e65000 rw-p 00000000 00:00 0                                  [heap]
    08e65000-08e86000 rw-p 00000000 00:00 0                                  [heap]
    08e86000-08ea7000 rw-p 00000000 00:00 0                                  [heap]
    08ea7000-08ec8000 rw-p 00000000 00:00 0                                  [heap]Aborted (core dumped)
    But when I start Arora as another user then I getting no errors and everything is working smoothly. I removed most of last programs I installed... still same. I reinstalled Arora and used "chown user:user -R *" for my "/home/user" folder.

    Why only one user getting those errors? I tested with "startx" without window manager with different users. I have'nt autostart for my window managers, always run them with command line from bash, depends on what I want. As I understood a file became locked related to my user account or home folder. Can you help me to find and fix it? In WindowMaker I used wmsystemtray and peksystray for testing with alltray.. it was'nt working good for Arora but for Firefox no problems.

    My brain crashed on that problem now. Please help me! Arora is my favorite and primary browser.

    Btw, I am using ArchLinux!

  2. #2
    Just Joined! Andy_Crowd's Avatar
    Join Date
    Sep 2013
    Location
    日不落
    Posts
    88

    Lightbulb [SOLVED] Arora Crash

    Hi!
    I solved the problem by renaming folder by folder and file by file and found the damaged file "bookmarks.xbel" in the "/home/user/.local/share/data/Arora/". When I renamed it... all the problems gone

    Thank you!

    You made me think

    More details is third bookmark item with URL length 144. It might be a bug after last Arora or ArchLinux update. When I removed that "long" URL, problem is also gone.
    Last edited by Andy_Crowd; 12-03-2013 at 08:58 PM. Reason: More details

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •