Find the answer to your Linux question:
Results 1 to 7 of 7
Hi I am using 64bitarch linux. I use a software named 'zekr' on daily basis for research purpose. This is a java based software. Previously this worked well on my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    18

    A java software (Zekr) is giving java error


    Hi
    I am using 64bitarch linux. I use a software named 'zekr' on daily basis for research purpose. This is a java based software. Previously this worked well on my arch installations but not this time. Now whenever I try to launch 'zekr.sh', it crashes with following error:
    Code:
    java version "1.7.0_51"
    OpenJDK Runtime Environment (IcedTea 2.4.5) (ArchLinux build 7.u51_2.4.5-1-x86_64)
    OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    #  SIGSEGV (0xb) at pc=0x00007f363ed37bd1, pid=3176, tid=139872297096960
    #
    # JRE version: OpenJDK Runtime Environment (7.0_51-b31) (build 1.7.0_51-b31)
    # Java VM: OpenJDK 64-Bit Server VM (24.51-b03 mixed mode linux-amd64 compressed oops)
    # Problematic frame:
    # C  [libsoup-2.4.so.1+0x6fbd1]  soup_session_feature_detach+0x11
    #
    # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
    #
    # An error report file with more information is saved as:
    # /tmp/hs_err_pid3176.log
    #
    # If you would like to submit a bug report, please include
    # instructions on how to reproduce the bug and visit:
    #   icedtea[dot]classpath[dot]org/bugzilla
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    #
    /usr/bin/zekr.sh: line 18:  3176 Aborted                 (core dumped) "$JAVA_CMD" $VM_ARGS -cp "$CLASS_PATH" $MAIN_CLASS $*
    As suggested here, I have also tried "ulimit -c unlimited" but no use. I have also tried by installing jdk from AUR but this also did not work and zekr gave error that java not found so I reverted back to open-jdk which worked with my previous installations.
    Here is the output of /tmp/hs_err_pid3176.log
    pastebin[dot]com/e11JAHyd
    However, it does not help much.
    Kindly help me to solve this problem.

  2. #2
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,067
    My guess is you need to run this using a different version of Java. This page indicates Sun's is required - that would probably mean Oracles is since they bought Sun's Java. Installation - ZekrWiki

  3. #3
    Just Joined!
    Join Date
    Feb 2012
    Posts
    18
    As you mentioned, I installed Oracle Java JRE 8 but still this software is giving same error.

  4. #4
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,067
    Does it indicate the error is coming from Oracle Java 8 or OpenJava. You'll have to set things up to use the Oracle JRE.

  5. #5
    Just Joined!
    Join Date
    Feb 2012
    Posts
    18
    Quote Originally Posted by gregm View Post
    Does it indicate the error is coming from Oracle Java 8 or OpenJava. You'll have to set things up to use the Oracle JRE.
    Oracle Java and OpenJava, both, are giving same error as mentioned in the first post. So I think that there may be something else wrong eventhough the log is pointing towards java. What do you think?
    The software (zekr) installs openjava as a dependency and this openjava works well with it. So I think openjava would be the appropriate version of java.

  6. #6
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,067
    A web search shows up a lot of material. It appears a change was made somewhere that produced some breakage related to Eclipse. Here is a fix that may help: https://groups.google.com/forum/#!ms...k/0nofWGKYYusJ

  7. #7
    Just Joined!
    Join Date
    Feb 2012
    Posts
    18
    Quote Originally Posted by gregm View Post
    A web search shows up a lot of material. It appears a change was made somewhere that produced some breakage related to Eclipse. Here is a fix that may help: groups[dot]google[dot]com/forum/#!msg/zekr/-y51pmZ6Mtk/0nofWGKYYusJ
    Thanks a lot. The problem is fixed now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •