Find the answer to your Linux question:
Results 1 to 4 of 4
have installed phpmyadmin on opensuse version 13.1 want to have acces to login without passwd You either have to change the root password in mysql, or allow an empty root ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    May 2013
    Posts
    212

    access to phpmyadmin without passwd - not possible


    have installed phpmyadmin on opensuse version 13.1

    want to have acces to login without passwd


    You either have to change the root password in mysql, or allow an empty root password in line 100 in /etc/phpMyAdmin/config.inc.php:


    i set the config accordingly

    line 92
    Code:
    // MySQL user
    $cfg['Servers'][$i]['user']                = 'root';
    
    // MySQL password (only needed with 'config' auth_type)
    $cfg['Servers'][$i]['password']            = '';
    
    // Allow access without password
    $cfg['Servers'][$i]['AllowNoPassword']     = true;
    
    // whether to allow root login
    $cfg['Servers'][$i]['AllowRoot']           = true;
    
    // Session to use for 'signon' authentication method
    $cfg['Servers'][$i]['SignonSession']       = '';
    cannot access with the following:

    use root
    pass empty


    what to do

    update:





    according this thread

    https://forums.opensuse.org/showthre...mysql-password

    i have the following options - note; this results are not an output of my work - i only have had a look a the methods and ways i can go...

    The normal way of setting a password for mysql does not work on opensuse 11.0

    Code:
        localhost:/etc # mysqladmin -u root password xxx
        mysqladmin: connect to server at 'localhost' failed
    see the following .,,,,
    Code:
      error: 'Access denied for user 'root'@'localhost' (using password: YES)'

    Suse is using some strange /etc/my.cnf file which has the following section
    # The following options will be passed to all MySQL clients
    [client]
    #password =xxx
    port = 3306
    socket = /var/lib/mysql/mysql.sock
    Using this password entry changes the "password: YES" or "password: NO" answer.
    Now I am totally lost on configuring mysql and doing such simple tasks as setting of root password.
    Any help appreaciated, also any introduction into the how and why suse does it the way it works (which is different to usually).

    again - not my results and findings - but i thought that this above mentioned thread is useful.


    see another interesting thead

    http://www.cyberciti.biz/faq/how-to-...-line-and-php/


    accordin this thread i did use the following code in terminal

    Code:
       
    $ mysql -u martin -h localhost -p
    
    
    mysql -u martin -h localhost -p
    Enter password:
    ERROR 1045 (28000): Access denied for user 'martin'@'localhost' (using password: YES)
    well - you see that i need to do something. there __ must ___ be a root passd for the mysql-db

    how to change / how to procceed now?

    look forward to hear from you
    Last edited by sayhello; 05-31-2014 at 03:17 PM.

  2. #2
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    896
    If you didn't set a root password, there isn't one.

    Connect to mysql as follows:
    mysql -u root

    Don't add the -p option. It should connect you as root without asking for password.
    Otherwise, you set a password.

    Here's how to change the root password if you forgot it:
    Reset Forgotten MySQL Root Password | HowtoForge - Linux Howtos and Tutorials

  3. #3
    Linux Newbie
    Join Date
    May 2013
    Posts
    212
    hello dear mizzle

    many many thanks for the hints - you are very very supportive....




    thanks for the hints...

    i tried out several things - and this works for me


    Code:
    mysql -u root -h localhost -p
    Enter password:
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 9
    Server version: 5.5.33-MariaDB openSUSE package
    
    Copyright (c) 2000, 2013, Oracle, Monty Program Ab and others.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    
    MariaDB [(none)]>
    welll now i know.--- the access to the db is with the following credentials is possible

    user root
    passwd: the passwd for the root user on the machine.

    guess that we subsequently can move aehead with our question of access for the phpmyadmin - can īt we?

    Mittzle - i really look forward to hear from you - in this thread and - even more in the other - (with the perl-script)


    Many thanks in advance.
    many many greetings

  4. #4
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    896
    I suppose you could change your phpmyadmin .conf file (the one you quoted in first post) to:
    $cfg['Servers'][$i]['password'] = 'password';

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •