Find the answer to your Linux question:
Results 1 to 3 of 3
Libre Office, missing USA language module Somehow I lost USA language in Libre Office. How to get it back? My dictionaries are properly installed: Code: [boris@e6410dl ~]$ ll /usr/share/myspell/ total ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    165

    Libre Office, missing USA language module


    Libre Office, missing USA language module
    Somehow I lost USA language in Libre Office. How to get it back?


    My dictionaries are properly installed:
    Code:
    [boris@e6410dl ~]$ ll /usr/share/myspell/
    total 5.2M
    -rw-r--r--. 1 root root 3.1K Apr  7 15:07 en_US.aff
    -rw-r--r--. 1 root root 522K Apr  7 15:07 en_US.dic
    -rw-r--r--. 1 root root 1.2K Sep 28  2003 hr_HR.aff
    -rw-r--r--. 1 root root 2.3M Sep 28  2003 hr_HR.dic
    -rw-r--r--. 1 root root  33K Sep 23  2011 nl_NL.aff
    -rw-r--r--. 1 root root 2.4M Sep 23  2011 nl_NL.dic
    [boris@e6410dl ~]$
    Libre Office is the only application that suffers from this issue. Other tools do show all available languages.

    gedit


    firefox


    thundrebird



    What is missing in my Libre Office installation?
    Is there a way to fix this?
    __________________
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100
    Fedora_20@Dell_Latitude_E6410
    Ubuntu_14.04_LTS@HP_Compaq_DC7100

  2. #2
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    165
    Also in Tools > Options > Language settings, English USA is not recognized. (Yes, I can select it but it does not check the spelling.)
    Fedora_20@Dell_Latitude_E6410
    Ubuntu_14.04_LTS@HP_Compaq_DC7100

  3. #3
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    165
    The following hunspell packages are installed on this machine.
    Code:
    [boris@e6410dl ~]$ yum list installed  *spell*
    Loaded plugins: changelog, fastestmirror, keys, langpacks, refresh-packagekit, remove-with-leaves, show-leaves, verify
    Loading mirror speeds from cached hostfile
     * fedora: fedora.mirror.root.lu
     * livna: ftp-stud.fht-esslingen.de
     * rpmfusion-free: mirrors.coreix.net
     * rpmfusion-free-updates: mirrors.coreix.net
     * rpmfusion-nonfree: mirrors.coreix.net
     * rpmfusion-nonfree-updates: mirrors.coreix.net
     * updates: www.mirrorservice.org
    Installed Packages
    gtkspell.x86_64                                          2.0.16-7.fc20                                           installed
    hunspell.x86_64                                          1.3.2-14.fc20                                           installed
    hunspell-en.noarch                                       0.20121024-7.fc20                                       @updates 
    hunspell-en-GB.noarch                                    0.20121024-7.fc20                                       @updates 
    hunspell-en-US.noarch                                    0.20121024-7.fc20                                       @updates 
    hunspell-hr.noarch                                       1:0.20040608-10.fc20                                    installed
    hunspell-nl.noarch                                       2.10-5.fc20                                             installed
    hunspell-sr.noarch                                       0.20130330-2.fc20                                       installed
    [boris@e6410dl ~]$
    I have removed all hunspell packages, except hunspell-en-US.noarch
    Code:
    [root@e6410dl boris]# yum list installed *spell*
    Loaded plugins: changelog, fastestmirror, keys, langpacks, refresh-packagekit, remove-with-leaves, show-leaves, verify
    Loading mirror speeds from cached hostfile
     * fedora: ftp.nluug.nl
     * livna: rpm.livna.org
     * rpmfusion-free: ftp.nluug.nl
     * rpmfusion-free-updates: ftp.nluug.nl
     * rpmfusion-nonfree: ftp.nluug.nl
     * rpmfusion-nonfree-updates: ftp.nluug.nl
     * updates: ftp.nluug.nl
    Installed Packages
    gtkspell.x86_64                                           2.0.16-7.fc20                                          installed
    hunspell.x86_64                                           1.3.2-14.fc20                                          installed
    hunspell-en-US.noarch                                     0.20121024-7.fc20                                      @updates 
    [root@e6410dl boris]#
    Now all LibreOffice applications have English (USA) in the language list and the spelling check works fine.

    Then I started installing other hunspell packages. The issue is resolved, spelling check is now alvailable for all languages.
    Fedora_20@Dell_Latitude_E6410
    Ubuntu_14.04_LTS@HP_Compaq_DC7100

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •