Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    sources.list problem with FreeCad installation...


    Hi all... I was trying to install FreeCad on my system and ran into a few problems. I still haven't mastered the sources.list file for aptitude and apt-get, so I was hoping for some help... Before anyone says, I'm on a Debian not Ubuntu, I know but I'm following what the site stated in that the installation was very similar.

    First I followed the instructions for putting a new package in, with this, as indicated in the FreeCad site

    https://launchpad.net/~freecad-maint...freecad-stable

    Code:
    root# add-apt-repository ppa:freecad-maintainers/freecad-stable
    You are about to add the following PPA to your system:
     This PPA repository hosts stable releases of FreeCAD for all supported versions of Ubuntu in 32 and 64-Bit architecture. These packages are more up to date than those found on the Ubuntu repositories.
     More info: https://launchpad.net/~freecad-maintainers/+archive/ubuntu/freecad-stable
    Press [ENTER] to continue or ctrl-c to cancel adding it
    
    Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.TkutA7XA0a --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 83193AA3B52FF6FCF10A1BBF005EAE8119BB5BCA
    gpg: requesting key 19BB5BCA from hkp server keyserver.ubuntu.com
    gpg: key 19BB5BCA: public key "Launchpad PPA for FreeCAD maintainers" imported
    gpg: Total number processed: 1
    gpg:               imported: 1  (RSA: 1)
    root#
    The next step is to update sources.list, and by the example I felt that this was what was wanted (I used $(uname -r) for the string "3.14-0.bpo.2-amd64"):

    Code:
    #
    # FreeCad entry
    #
    deb http://ppa.launchpad.net/freecad-maintainers/freecad-stable/debian 3.14-0.bpo.2-amd64 main
    deb-src http://ppa.launchpad.net/freecad-maintainers/freecad-stable/debian 3.14-0.bpo.2-amd64 main
    This was how it's described on the site:

    Code:
    deb http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu YOUR_UBUNTU_VERSION_HERE main 
    deb-src http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu YOUR_UBUNTU_VERSION_HERE main
    When I try the next step, it chokes on the entry that I made in the sources.list file, I believe.


    Code:
    root# apt-get update
    Hit http://security.debian.org wheezy/updates Release.gpg
    Hit http://http.us.debian.org wheezy Release.gpg                                                                        
    Hit http://http.us.debian.org wheezy Release                                                                            
    Hit http://security.debian.org wheezy/updates Release                                             
    Hit http://security.debian.org wheezy/updates/main amd64 Packages    
    Ign http://ppa.launchpad.net 3.14-0.bpo.2-amd64 Release.gpg                              
    Hit http://security.debian.org wheezy/updates/main Translation-en     
    Ign http://ppa.launchpad.net wheezy Release.gpg                         
    Hit http://http.debian.net wheezy-backports Release.gpg   
    Ign http://ppa.launchpad.net wheezy Release.gpg           
    Ign http://ppa.launchpad.net 3.14-0.bpo.2-amd64 Release
    Hit http://http.debian.net wheezy-backports Release
    Ign http://ppa.launchpad.net wheezy Release     
    Ign http://ppa.launchpad.net wheezy Release
    Hit http://http.debian.net wheezy-backports/main amd64 Packages/DiffIndex
    Hit http://http.debian.net wheezy-backports/main Translation-en/DiffIndex
    Err http://ppa.launchpad.net 3.14-0.bpo.2-amd64/main Sources                                                                                                             
      404  Not Found
    Err http://ppa.launchpad.net 3.14-0.bpo.2-amd64/main amd64 Packages                                                                                                      
      404  Not Found
    Ign http://ppa.launchpad.net 3.14-0.bpo.2-amd64/main Translation-en_US                                                                                                   
    Ign http://ppa.launchpad.net 3.14-0.bpo.2-amd64/main Translation-en                                                                                                      
    Err http://ppa.launchpad.net wheezy/main Sources                                                                                                                         
      404  Not Found
    Err http://ppa.launchpad.net wheezy/main amd64 Packages                                                                                                                  
      404  Not Found
    Ign http://ppa.launchpad.net wheezy/main Translation-en_US                                                                                                               
    Ign http://ppa.launchpad.net wheezy/main Translation-en                                                                                                                  
    Err http://ppa.launchpad.net wheezy/main Sources                                                                                                                         
      404  Not Found
    Err http://ppa.launchpad.net wheezy/main amd64 Packages                                                                                                                  
      404  Not Found
    Ign http://ppa.launchpad.net wheezy/main Translation-en_US                                                                                                               
    Ign http://ppa.launchpad.net wheezy/main Translation-en
    W: Failed to fetch http://http.us.debian.org/debian/dists/wheezy/Release  Unable to find expected entry 'universe/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)
    
    W: Failed to fetch http://ppa.launchpad.net/freecad-maintainers/freecad-stable/debian/dists/3.14-0.bpo.2-amd64/main/source/Sources  404  Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/freecad-maintainers/freecad-stable/debian/dists/3.14-0.bpo.2-amd64/main/binary-amd64/Packages  404  Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu/dists/wheezy/main/source/Sources  404  Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu/dists/wheezy/main/binary-amd64/Packages  404  Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu/dists/wheezy/main/source/Sources  404  Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu/dists/wheezy/main/binary-amd64/Packages  404  Not Found
    
    E: Some index files failed to download. They have been ignored, or old ones used instead.
    root@debian:/home/jack/Downloads/hma#
    I am running a backport, and don't know if that does anything or not...

    I'm hoping that someone will spot what I tried to do, incorrectly and I can get this up and running...

    Thanks

    Jack

  2. #2
    I did find that the 'your ubuntu version' would probably be 'wheezy'. However I still had errors when I tried to update the package. Even when I tried to make the source lines read for ubuntu, it failed. There appears to be no where to get answers from the FreeCad people.

    Jack

  3. #3
    Linux Engineer drl's Avatar
    Join Date
    Apr 2006
    Location
    Saint Paul, MN, USA / CentOS, Debian, Slackware, {Free, Open, Net}BSD, Solaris
    Posts
    1,472
    Hi.

    I have not used FreeCAD that I can recall, however:
    Notes for Debian users

    Because of a licensing conflict between third-party libraries required by FreeCAD, the freecad package was removed from the current Debian stable (wheezy) repository. This will be solved when the next stable release of FreeCAD comes out. In the meanwhile, you can either compile FreeCAD or use an alternate build.

    You should also note that although Ubuntu is based on Debian, the Ubuntu PPA packages are NOT compatible with Debian.
    -- Download - FreeCAD Documentation

    That suggests that one would wait for the next rev, use Ubuntu, or try compiling: CompileOnUnix - FreeCAD Documentation

    Best wishes ... cheers, drl
    Welcome - get the most out of the forum by reading forum basics and guidelines: click here.
    90% of questions can be answered by using man pages, Quick Search, Advanced Search, Google search, Wikipedia.
    We look forward to helping you with the challenge of the other 10%.
    ( Mn, 2.6.n, AMD-64 3000+, ASUS A8V Deluxe, 1 GB, SATA + IDE, Matrox G400 AGP )

  4. $spacer_open
    $spacer_close
  5. #4
    -->
    Drl: Thanks, I didn't find that note that you added, I assume I missed it on the FreeCad page? I do have the source, but haven't found out how to successfully build it. I will read further and try that approach. I'm hoping that Debian will have it soon as I would like to learn a 3D cad program to assist in the many plans I do. If you didn't find that 'note to Debian users' in the freecad area, please let me know where you found it.

    Sometimes I think I'm going blind...

    Thanks

    Jack

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •