Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Question regarding tomcat on CentOS


    New to Linux, but learning something new each day. Decided to try installing tomcat on my CentOS VM. The problem was, when I ran

    Code:
    yum install tomcat
    it installed tomcat just fine, but starting the tomcat service and going to localhost:8080 left me with a blank page.

    So I hit google, and found some users with a similar problem. I took their advice and ran this in the terminal

    Code:
    yum install tomcat-admin-webapps.noarch tomcat-docs-webapp.noarch tomcat-javadoc.noarch tomcat-systemv.noarch tomcat-webapps.noarch
    and it fixed it (I could now see the tomcat welcome page, as opposed to a blank page). I guess what I'm wondering is why did this fix the problem?

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    4,087
    -->
    I don't *know* why, but I'd guess that installing the admin pages provided you with a default configuration to get things working, enough to get you using the configuration pages anyway. If you weren't going to use them, you would probably have had some manual configuration to carry out to make the package work
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •