Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Can't compile fbsplash, "-o: not found"


    I'm trying to compile frontend utility fbsplash; it is last updated in 2011, I do not think it's too old.
    I'm doing this under Micro Core, so it may lack some very basic tools I don't know of.

    The source package must be configured with autotools; I've installed: autoconf, automake, libtool, intltool, gettext, perl5 and other basic stuff from compiletc extension, including gcc, g++, make and so on. The package needs libjpeg, libpng and pgm (devs), they're installed as well.

    The source package seems to be lacking some template files like "missing", em... and some more. So if I run "autoconf", it exits. So I must run "autoreconf -vif" first, then I run "automake". This generates a "configure" file, so then I run "./configure" to get a "Makefile". Then I run "make".

    But, when it starts working with the very first libjpeg.a in its list, it crashes saying something like this:
    make[3] 02: command not found
    make[3] 02: command not found
    make[3] 02: command not found
    make[3] 02: command not found
    make[3] 02: command not found
    /bin/sh: -o: not found
    I've read that this may be caused by gettext not installed. But I definitely have gettext installed, both gettext and gettext-dev.
    I've read that there may not be "msgfmt" in my /usr/bin. Yeah, it really wasn't there, but I created a symlink
    ln -s /usr/local/bin/msgfmt /usr/bin
    and reconfigured and ran make and it crashed again. (I have all the stuff in /usr/local/bin, yeah; msgfmt and some other msg* stuff. My sh is in /usr/bin, though).

    I tried doing some guess-like stuff like run "gettextize" in the source directory. Then it created a po/ directory in there and rejected to make because there where no Makefile in this po/ directory. Only Makefile.in.in (exactly) and no configure.ac, so I couldn't autoconf this po/ or automake it or something.
    The configure script does not contain an option like --disable-nls, as I felt that all this crap with gettext somewhat concern this...

    So, what may be wrong?

  2. #2
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Saint Paul, MN
    Posts
    818
    It looks like you have a bad option for optimization defined as "O2" rather than "-O2". Options need the dash.

  3. #3
    Quote Originally Posted by alf55 View Post
    It looks like you have a bad option for optimization defined as "O2" rather than "-O2". Options need the dash.
    Thought so... Can I override the usage of this option outside the Makefile? I don't even know which one of Makefiles to look through.
    And, yeah, O2 is quite understandable, but what about -o?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Saint Paul, MN
    Posts
    818
    -->
    -o outputfilename

    Typical file.c -o file.o
    file.o -o myexecuatablefilename
    ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •