Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Installing software packages on Linux 7.1


    Hi All,

    I am a newbie to Linux and I would like to have some help regarding installation of software packages on Oracle Linux 7.1. I did a minimal install of the OS and also installed Compatibility Libraries as an Addon. Amongst other settings, I disabled SELinux, updated all packages using yum update and added EPEL release 7.5 to yum. Next, I did a yum grouplist to see the available packages and started installing required packages using yum groupinstall command.

    Now some packages like Additional Development could not be installed because I did not install mariadb-devel packages. Questions: What's the best way to install mariadb? Will SQL 5.6 do the same job?

    The main issue I found is I could not install many packages like Console Internet Tools, General Purpose Desktop, Compatibility Libraries, Java Platform, NFS File server and so on. I can see these packages are the the available groups list but when I try to install, yum does not find any packages to install for these packages. Question: What I am missing here? Why can I use yum to install some packages but not others?

    I redownloaded the public yum repo file and then tried to install but that did not help.

    I also tried mounting the iso file for Oracle Linux 7.1 (downloaded from the oracle website), created a repo file for yum to use the iso file while disabling all other repo files and tried to install the packages but that didn't help either.

    I then downloaded the public-yum-ol6.repo repo file and enabled it while disabling other repo files. This time yum did find packages to install but there version issues.

    What am I missing here?

    Thank you for your help.

    Regards,

    Vishal

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    14,038
    Some of these may be in repositories that you have not installed on your system, such as epel or atrpms. Missing the epel repository is a common problem. You should be able to install that with the command: yum install epel-release.noarch

    Or, you may find a link to it on the Oracle Linux site.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    -->
    Hi Rubberman,

    Thank you for your reply. I did add epel relaese 7.5 to yum. Please see the output for the yum repolist command below:

    [root@Server12 ~]# yum repolist
    Loaded plugins: fastestmirror, langpacks
    epel/x86_64/metalink | 19 kB 00:00:00
    epel-source/x86_64/metalink | 18 kB 00:00:00
    epel-source | 3.7 kB 00:00:00
    epel-source/x86_64/primary_db | 1.3 MB 00:00:00
    (1/2): epel-source/x86_64/updateinfo | 441 kB 00:00:00
    (2/2): epel-source/x86_64/pkgtags | 1.6 MB 00:00:00
    Loading mirror speeds from cached hostfile
    * epel: mirrors.ukfast.co.uk
    * epel-source: mirrors.ukfast.co.uk
    repo id repo name status
    epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 8,276
    epel-source/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 - Source 0
    ol7_UEKR3/x86_64 Latest Unbreakable Enterprise Kernel Release 3 for Oracle Linux 7Server (x86_64) 221
    ol7_latest/x86_64 Oracle Linux 7Server Latest (x86_64) 9,836
    repolist: 18,333

    Please see below the output when I run the yum groupinstall "Console Internet Tool" command

    [root@Server12 ~]# yum groupinstall "Console Internet Tools"
    Loaded plugins: fastestmirror, langpacks
    Loading mirror speeds from cached hostfile
    * epel: mirrors.ukfast.co.uk
    * epel-source: mirrors.ukfast.co.uk
    Warning: Group console-internet does not have any packages to install.
    Maybe run: yum groups mark install (see man yum)
    No packages in any requested group available to install or update

    I only had the langpacks yum plugin at first but I then added the fastestmirror plugin thinking it could be the plugin's fault. I also tried installing from the Oracle Linux 7.1 ISO image but again yum did not find any packages to install.

    What else can we check?

    Thank you again for your input.

    Regards,

    Vishal

$spacer_open
$spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •