Find the answer to your Linux question:
Results 1 to 7 of 7
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    How to set default page orientation in Okular for printing


    Is there a way to change the default page orientation for printing documents in Okular? What I am seeing is that Okular is auto-detecting the page orientation and I need it to always default to portrait regardless if it the document is landscape or portrait.

    I am running CentOS 6.6 with KDE & a Brother MCFJ6520DW printer.

    I have tried running system-config-printer and selecting the properties of the printer and changing the orientation from “Automatic Rotation” to “Portrait (no rotation)”, but it still auto-detects the document type and sets the orientation accordingly. I don’t see any options in CUPS for orientation.

    Any ideas how to change this behavior?

  2. #2
    I wish I could tell you, but I've having a very similar problem myself. Although the printer is a Lexmark CS310dn, it is set internally for 'duplex' (print front and back) and landscape orientation. These are ignored when printing via the command line or via a GUI. I'm hoping that others will see it and assist both of us...

    Debian (up to date) 64 bit OS.

    Jack

  3. #3
    Yes, unfortunately, I still have the problem and have not been able to find a solution.

  4. $spacer_open
    $spacer_close
  5. #4
    I have switched over to Ubuntu (I know it's still Debian), since I've found it much easier to just run an encrypted file system. I also have noticed that my output to my printer is still different than the defaults of the printer. It appears to have it's own defaults, somewhere. I've looked at CUPS and think it must be there somewhere as it was installed on both OS's. Do you run CUPS?

    Jack

  6. #5
    Quote Originally Posted by jkwilborn View Post
    I have switched over to Ubuntu (I know it's still Debian), since I've found it much easier to just run an encrypted file system. I also have noticed that my output to my printer is still different than the defaults of the printer. It appears to have it's own defaults, somewhere. I've looked at CUPS and think it must be there somewhere as it was installed on both OS's. Do you run CUPS?

    Jack
    Yes, I am running CUPS. It's version 1.4.2 on CentOS 6.6.

  7. #6
    It must be something that CUPS is doing to cause that. I've looked through my configuration and it's set for long double sided. Even when I lp a file that is two pages or more it still prints on only one side. It seems like this would be an obvious problem and I guess I'll have to go over to CUPS site and ask there. If I find anything, I will post it here...

    Jack

  8. #7
    -->
    I wish I could say what exactly caused it to start working. I was changing IP's around and accidently hit a card option in the networking. The printer reset, I set it back, it reset. Now when I print anything it's double sided. This was yesterday, so it's been a while. I can't more definitive, sorry.

    Sorry jjscott, I couldn't help you with more. Maybe a factory reset then set it up again???

    Thanks to all who viewed this thread...

    Jack

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •