Find the answer to your Linux question:
Results 1 to 7 of 7
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Iceweasel, causes display of "Update required" message...

    Hi all... I'm not sure if this is the proper place for this and I had difficulty in the search mechanism to find much...

    Iceweasel on Debian 7.8, my default page is When it starts Google comes up then I get Google screen it's quickly replaced with a message from Mozilla that I need to upgrade my browser. It is the latest, but what's curious is that if I say "OK" it's wanting to download is an exe file.

    I've used Aptitude to remove and reinstall Iceweasel, but the same things happen. I've also unchecked the upgrade check box, I believe, yet it continues to occur.

    What's really frustrating is that I can not back up, as that information appears to ignored. So when it happens, that window is stuck on the Mozilla message.

    It appears to me Iceweasel thinks my machine is a Windows box, by evidence of the filename with an exe extension. Obviously not a Linux file.

    Is there some way to see why it thinks I'm a windows machine? Is there some kind of thing stored that says it's a Windows OS?

    It also does it on other things besides Google, so I don't think it's them. It will load the requested page then go to the Mozilla message..

    Any suggestions?



  2. #2
    It's called a user agent. To answer your query about

    Is there some way to see why it thinks I'm a windows machine?
    What's My User Agent?

  3. #3
    Linux Guru
    Join Date
    Dec 2013
    is it iceweasel itself, or is it the google home page?
    have you tried starting iceweasel with a blank page?

    how have you installed iceweasel?
    which version is it?
    maybe it really needs to be updated (these are all seperate questions)?

  4. $spacer_open
  5. #4
    It doesn't seem to be just Google related. I get it via other sites also. Usually anything that has some kind of video, for adds and stuff... Since then I've followed one suggestion by Mozilla and now I have appear to have broken my Linux! Only memory of what may have happened with 'Aptitude'. I was removing Iceweasel, Aptitude stated it was going to remove some items, I let it. Now when I boot in Linux I get only a TTY terminal and a "Debian Login:". Is there a way to back out that change, even though I've reinstalled Iceweasel? It would have to be command line driven as I can't get to a GUI, yet...

    I've wanted to move to Jessi, and was hoping that I could move, this may stimulate it...



  6. #5
    Thanks, but I did look into this, but couldn't find a way to locate the string. I did try installing a plugin that handles the "User Agent", but could find no information on how to enter the required information, so it died there... I will keep this link...



  7. #6
    Linux Guru
    Join Date
    Dec 2013
    Victoria, B.C. Canada
    I suspect it's telling you need to update your flash player.

  8. #7
    Having upgraded to the 8.2 debian, I'm not having the problem anymore. I believe it was thinking I had a windows platform and kept trying to get me to upgrade. The main difference is you couldn't say no, it just hung that tab. I know it wasn't the flash player, I was hoping that someone could tell me what my machine sends to let them know the machine type...


    I will mark this solved...


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts