Find the answer to your Linux question:
Results 1 to 7 of 7
Cannot change MAC address on wireless card: # ifconfig eth2 hw ether 00:05:6f:62:ea:b3 this is what i get: SIOCSIFHWADDR: Input/output error ***************** Am running Mandrake 10.1 kernel is 2.6.8 something ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3

    error changing MAC address - ifconfig ethX hw ether xx:xx:xx


    Cannot change MAC address on wireless card:
    # ifconfig eth2 hw ether 00:05:6f:62:ea:b3

    this is what i get:

    SIOCSIFHWADDR: Input/output error

    *****************
    Am running Mandrake 10.1
    kernel is 2.6.8 something
    wireless card is netgear wg511 (prismGT chipset - prism54 driver)
    wireless card is configured properly (at least it works)

    To be precise:

    i do:
    # ifconfig eth2 down
    # ifdown eth2

    then

    # ifconfig eth2
    eth2 Link encap:Ethernet HWaddr 00:09:5B:C2:F08
    BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:78 errors:0 dropped:0 overruns:0 frame:0
    TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:6056 (5.9 Kb) TX bytes:1212 (1.1 Kb)
    Interrupt:9


    # iwconfig eth2
    eth2 NOT READY! ESSID:"BTVOYAGER-BE" Nickname:"achilles"
    Mode:Managed Channel:6 Access Point: 00:00:00:00:00:00
    Tx-Power=31 dBm Sensitivity=0/200
    Retry min limit:0 RTS thr=0 B Fragment thr=0 B
    Encryption key:off
    Link Quality:177/0 Signal level:-79 dBm Noise level:-181 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    then

    # ifconfig eth2 hw ether 00:05:6f:62:ea:b3
    SIOCSIFHWADDR: Input/output error

    Next, when I do:
    # ifconfig eth2 up

    everything is ok, but if I follow it with:

    # ifup eth2

    this is what is get:

    grep: /etc/sysconfig/networking/default/ifcfg-*: No such file or directory
    interface 'eth2' not found
    Error for wireless request "Set NWID" (8B02) :
    SET failed on device eth2 ; Operation not supported.

    So, want to change MAC on eth2, but can't.
    Have really done A LOT of google search, but without result.
    Can anyone please help?
    thx a lot!

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Are the driver installed properly?
    If not, Here's a good tutorial

    Otherwise This should help you get this resolved

    Also remember NOT to double/ cross post
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Remember that you must be superuser to change anything with ifconfig.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3
    thanks to both of you.

    Still a problem.
    Did download macchanger v1.5 and installed it. Then ran it from root, here is what I got:

    # macchanger -s eth2
    Current MAC: 00:09:5b:c2:f0:d8 [wireless] (Netgear MA701, MA401RA)

    # macchanger --mac=00:05:6f:62:ea:b3 eth2
    Current MAC: 00:09:5b:c2:f0:d8 [wireless] (Netgear MA701, MA401RA)
    ERROR: Can't change MAC: interface up or not permission: Input/output error

    obviously before running the commands above, I did run under root

    # ifdown eth2

    and

    # ifconfig eth2 down


    any more ideas?
    thx


    PS:

    1) all the commands I gave were in superuser mode. but thanks anyway!

    2) I believe the drivers for the card are properly installed. Al least Mandrake does recognize automotically my card (v 2.6.8 has got pcmcia support - the module loads automotically I believe).
    But I did not patch the kernel.
    Regarding the firmware, I got it from prsim54.org and copied it into
    /usr/lib/hotplug/firmware/.
    Anyway, the wireless card does work - i can ping any host properly, and for example I can also run kismet.

  5. #5
    Just Joined!
    Join Date
    Sep 2006
    Posts
    1
    Sorry, I don't know if this post is old or not. Either way, it still doesn't solve my problem. I'm having trouble with MAC changing, obviously.

    I got it to work, that's not a problem. The MAC changes fine...But my internet won't go up.

    I looked in my networking in Gnome, and it says my wlan0 is active, but when I go to google..Page cannot be found.

    I've tried to do "dhclient" (Recommended by a friend), but no avail. If you could help me get this working, it's be great...

    Code:
    ifconfig wlan0 down
    
    ifconfig wlan0 hw ether 00:00:00:00:00:01
    
    ifconfig wlan0 up

  6. #6
    Just Joined!
    Join Date
    Jan 2009
    Location
    holland
    Posts
    12

    Hi same sort of problem here xD

    bla bla
    MACADDR=xxxxxxxxxxxx safe file as root not as user. in the ethernetnic file

  7. #7
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hi, vastvet, and welcome to the forums!

    Not sure if you are replying to the current thread or are asking for assistance with a similar issue.

    If it's the latter, please start a new thread of your own describing any problems that you are having since this thread is 4 years old already.

    Sorry for any inconvenience.
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •