Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Samba configuration help


    Hi,

    I'm currently studying samba. Unfortunately I seemed to have messed something up. So I was wondering if someone could tell me what I am doing wrong.
    Still have to do permission, but working in steps, but testparm is giving errors suddenly and I don't know why.

    A bit of the exercise I need to do :

    4 users: 2 of which do administration and rutger the IT-guy (provided by windows 2008 server)

    shared folders :
    -algemeen : folder for all
    -administratie : folder just for the administration
    -software : read only, rutger read and write
    -iso : read only

    rutger also has to have access to all home dir's (including root) as well as /mnt and /var/log


    The smb.conf.rutger / administratie file just has the service + browsable = yes so they only show for valid users.

    This is my smb.conf file

    [global]
    workgroup = BLATTLAUFER
    security = ADS
    REALM = blattlaufer.gmbh

    passdb backend = tdbsam

    printing = cups
    printcap name = cups
    load printers = yes
    cups options = raw

    idmap uid = 10000-20000
    idmap gid = 10000-20000

    winbind use default domain = Yes

    [homes]
    comment = Home Directories
    path = /%S
    valid users = %S, %D%w%S
    browsable = yes
    read only = No
    inherit acls = Yes

    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browsable = No

    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = root
    create mask = 0664
    directory mask = 0775

    [Algemeen]
    comment = algemene share
    path = /share/algemeen
    browseable = yes

    [Administratie]
    comment = administratieve folder
    path = /share/administratie
    browsable = no
    writable = yes
    valid users = Darryl, Harry
    # valid users = administratie
    include = /etc/samba/smb.conf.administratie


    [Software]
    comment = software folder
    path = /share/software
    browsable = yes
    read only = yes

    [Iso]
    comment = iso folder
    path = /share/iso
    browsable = yes
    read only = yes

    # rutger

    [mount]
    comment = mount folder
    path = /mnt
    browsable = no
    valid users = rutger
    include = /etc/samba/smb.conf.rutger

    [logs]
    comment = log folder
    path = /var/log
    browsable = no
    valid users = rutger
    include = /etc/samba/smb.conf.rutger

    [Root]
    comment = root folder
    path = /root
    browsable = no
    valid users = rutger
    include = /etc/samba/smb.conf.rutger

    [Home]
    comment = home folder
    path = /home
    browsable = no
    valid users = rutger
    include = /etc/samba/smb.conf.rutger


    This is my testparm

    Load smb config files from /etc/samba/smb.conf
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    WARNING: The "idmap uid" option is deprecated
    WARNING: The "idmap gid" option is deprecated
    Processing section "[homes]"
    Processing section "[printers]"
    Processing section "[print$]"
    Processing section "[Algemeen]"
    Processing section "[Administratie]"
    Processing section "[administratie]"
    Processing section "[Software]"
    Processing section "[Iso]"
    Processing section "[mount]"
    Processing section "[mount]"
    Processing section "[software]"
    Processing section "[root]"
    WARNING: No path in service root - making it unavailable!
    NOTE: Service root is flagged unavailable.
    Processing section "[home]"
    WARNING: No path in service home - making it unavailable!
    NOTE: Service home is flagged unavailable.
    Processing section "[logs]"
    WARNING: No path in service logs - making it unavailable!
    NOTE: Service logs is flagged unavailable.
    Processing section "[logs]"
    NOTE: Service logs is flagged unavailable.
    Processing section "[mount]"
    Processing section "[software]"
    Processing section "[root]"
    WARNING: No path in service root - making it unavailable!
    NOTE: Service root is flagged unavailable.
    Processing section "[home]"
    WARNING: No path in service home - making it unavailable!
    NOTE: Service home is flagged unavailable.
    Processing section "[logs]"
    NOTE: Service logs is flagged unavailable.
    Processing section "[Root]"
    NOTE: Service root is flagged unavailable.
    Processing section "[mount]"
    Processing section "[software]"
    Processing section "[root]"
    NOTE: Service root is flagged unavailable.
    Processing section "[home]"
    WARNING: No path in service home - making it unavailable!
    NOTE: Service home is flagged unavailable.
    Processing section "[logs]"
    NOTE: Service logs is flagged unavailable.
    Processing section "[Home]"
    NOTE: Service home is flagged unavailable.
    Processing section "[mount]"
    Processing section "[software]"
    Processing section "[root]"
    NOTE: Service root is flagged unavailable.
    Processing section "[home]"
    NOTE: Service home is flagged unavailable.
    Processing section "[logs]"
    NOTE: Service logs is flagged unavailable.
    Loaded services file OK.
    WARNING: You have some share names that are longer than 12 characters.
    These may not be accessible to some older clients.
    (Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
    Server role: ROLE_DOMAIN_MEMBER

  2. #2
    -->
    just found it myself.

    I still had to put in 'path = ...' in the include conf files.

    Didn't see it in the documentation I had.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •