Find the answer to your Linux question:
Results 1 to 8 of 8
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Configuring Secure Boot when installing any package


    Lately when I try to install anything I get this message <screenshot attached>

    I can't close it nor click Ok. The only way is to close the terminal, but then many folders remains locked (apt-get don't release them untill restart).
    What should I do? I can't disable SB, cause I dualboot and GRUB needs it enabled.

    Linux mint 18.1
    EDIT:
    Link to screenshot:
    preview.ibb.co/kBuiwQ/UEFI_SB.png
    Attached Images Attached Images
    Last edited by bld; 04-15-2017 at 03:01 PM.

  2. #2
    Linux Guru
    Join Date
    Dec 2013
    Posts
    2,747
    something must have changed recently on this site, i cannot see the attached images anymore.
    my security addons are set to full block for this site, and that won't change.

    so please, describe what you see or host your screenshot on an external site like imgur or postimg.org.

    thank you.

    and what are you trying to install and how?
    has this always been or only recently?
    what happened immediately prior to the problem starting to occur?
    is your system up-to-date?

  3. #3
    I edited the post with link.

    It happened only for the few last times.
    It happens every time now when I try to install any package using apt-get command.
    My system is up to date.
    I don't know what might caused this, the only things I was changing recently is installing some developer tools (clang, anaconda etc.), changed bluetooth manager to blueman and removed apm package.

    Sometimes when I get this message and restart my computer, I get message
    E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
    After I run it of course the message about Secure Boot shows again.

    In case there are further issues with the image, I post text from the notification.

    Code:
    Package configuration
    
    
     ┌────────────────────────┤ Configuring Secure Boot ├────────────────────────┐
     │                                                                           │ 
     │ Your system has UEFI Secure Boot enabled.                                 │ 
     │                                                                           │ 
     │ UEFI Secure Boot is not compatible with the use of third-party drivers.   │ 
     │                                                                           │ 
     │ The system will assist you in toggling UEFI Secure Boot. To ensure that   │ 
     │ this change is being made by you as an authorized user, and not by an     │ 
     │ attacker, you must choose a password now and then use the same password   │ 
     │ after reboot to confirm the change.                                       │ 
     │                                                                           │ 
     │ If you choose to proceed but do not confirm the password upon reboot,     │ 
     │ Ubuntu will still be able to boot on your system but the Secure Boot      │ 
     │ state will not be changed.                                                │ 
     │                                                                           │ 
     │ If Secure Boot remains enabled on your system, your system may still      │ 
     │ boot but any hardware that requires third-party drivers to work           │ 
     │ correctly may not be usable.
    EDIT:
    I don't know what I did but somehow I managed to go to another screen (that asks for a password for secure boot) while skipping 1 screen in between.
    Enter a password for Secure Boot. It will be asked again after a reboot.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    2,185
    Just guessing. You installed some diver (video?) which is not secure boot compatible. Is there any particular reason you keep the secure boot enabled? Did you install any driver from outside of Mint repos?

  6. #5
    If I remember correctly, GRUB2 needed Secure Boot enabled.
    I don't think it's issue of video driver since my Mint even don't want to change them (it still uses nouveau despite the fact I downloaded NVIDIA, and using diffrent method for installing it it recommends different versions of NVIDIA driver...). After trying to install them I didn't have this message.
    I don't remember installing any drivers from outside Mint repo.

    EDIT:
    After running sudo dpkg --configure -a I got this:
    Setting up shim-signed (1.27~16.04.1+0.9+1474479173.6c180c6-1ubuntu1) ...
    Installing for x86_64-efi platform.

    Then the message poped up. I managed to turn it off and then it continued setting everything up. Maybe it's related to this?
    EDIT2:
    As it's "shim-signed: Secure Boot chain-loading bootloader (Microsoft-signed binary)" I think it is related.
    Maybe signing the package by my PC to make Secure Boot trust them will stop this message?
    (I have to dig into that, never did that before)
    Last edited by bld; 04-15-2017 at 04:14 PM.

  7. #6
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    2,185
    Grub2 does not require secure boot enabled.
    I'm not a Mint user, but I think your attempt to install nVidia driver by hand may have caused this after all. It may have produced an unsigned kernel module.

  8. #7
    I don't think that's the case, because I didn't have such messages after installing these drivers.
    Also, currently I have only Nvidia-340 installed by Driver Manager and nvidia-prime installed trought terminal.

  9. #8
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    2,185
    -->
    Well, you can revert back to nouveau and see if the problem goes away or you can disable secure boot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •