Find the answer to your Linux question:
Results 1 to 4 of 4
I am trying to install gDesklets ( an OSX-like dock application for gnome) but I'm having trouble compiling it. I think I don't have the perl XML parser or something. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Belgium
    Posts
    5

    ./configure problem (XML Perl parser??)


    I am trying to install gDesklets ( an OSX-like dock application for gnome) but I'm having trouble compiling it. I think I don't have the perl XML parser or something. The distro is Ubuntu btw...
    this is what I get when I type ./configure ...

    psyki@ubuntu:/data/themes/OSX/gDesklets-0.33.1 $ ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... mawk
    checking whether make sets $(MAKE)... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking for gcc... gcc
    checking whether we are using the GNU C++ compiler... yes
    checking whether gcc accepts -g... yes
    checking dependency style of gcc... gcc3
    checking for gcc option to accept ANSI C... none needed
    checking how to run the C preprocessor... gcc -E
    checking for egrep... grep -E
    checking for ANSI C header files... yes
    checking for perl... /usr/bin/perl
    checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Make sure you have this library (libxml2.so.2) as it is required for your gDes package...
    also, Take a look here
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Belgium
    Posts
    5
    thanks for the quick reply

  4. #4
    Just Joined!
    Join Date
    Jun 2006
    Posts
    2
    what i want to know is where this Dock is as now i have installed gDesklets i cant find the actually dock. so if anyone has the link to where the dock is it aould be greatly appreciated

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •