Find the answer to your Linux question:
Results 1 to 3 of 3
Hello everybody, I am new to Amanda. In company where I work as a Network Administrator we have implemented an Amanda Backup System. The former admin has done all the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    69

    new to amanda - need help (err:cannot determine first slot)


    Hello everybody,

    I am new to Amanda. In company where I work as a Network Administrator we have implemented an Amanda Backup System. The former admin has done all the work.

    I have never configured/worked with amanda.

    It seems I have a problem with tape changers and I can't find the solution.


    Here I need your help.


    I get the following error$amtape site_name current)
    amtape: could not get changer info: cannot determine first slot



    The report from Amanda looks like this:

    *** A TAPE ERROR OCCURRED: [new tape not found in rack].
    Some dumps may have been left in the holding disk.
    Run amflush to flush them to tape.
    The next tape Amanda expects to use is: a new tape.
    The next new tape already labelled is: site_name01.

    FAILURE AND STRANGE DUMP SUMMARY:
    server /home lev 3 FAILED [no more holding disk space]
    server /home/samba/construction lev 3 FAILED [no more holding disk space]
    server /home/samba/pub lev 2 FAILED [no more holding disk space]
    server /home/samba/office lev 2 FAILED [no more holding disk space]
    server /var/www lev 1 FAILED [no more holding disk space]

    ...............................................

    etc

    .................................................

    The amanda.conf looks like this:


    org "site_name" # your organization name for reports
    mailto "amanda" # space separated list of operators at your site
    dumpuser "amanda" # the user to run dumps under



    inparallel 4 # maximum dumpers that will run in parallel
    netusage 6000 Kbps # maximum net bandwidth for Amanda, in KB per sec


    dumpcycle 7 days # the number of days in the normal dump cycle
    runspercycle 7 days # the number of amdump runs in dumpcycle days
    tapecycle 8 tapes # the number of tapes in rotation


    bumpsize 20 Mb # minimum savings (threshold) to bump level 1 -> 2
    bumpdays 1 # minimum days at each level
    bumpmult 4 # threshold = bumpsize * bumpmult^(level-1)


    runtapes 1 # number of tapes to be used in a single run of amdump
    tpchanger "chg-zd-mtx" # the tape-changer glue script
    tapedev "/dev/nst0" # the no-rewind tape device to be used
    #rawtapedev "/dev/null" # the raw device to be used (ftape only)
    #changerfile "/var/lib/amanda/DailySet1/changer"
    #changerfile "/var/lib/amanda/DailySet1/changer-status"
    #changerfile "/etc/amanda/DailySet1/changer.conf"
    changerdev "/dev/sg0"


    tapetype DellHW # what kind of tape it is (see tapetypes below)
    labelstr "^site_name[0-9][0-9]*$" # label constraint regex: all tapes must match

    holdingdisk hd1 {
    comment "main holding disk"
    directory "/cache" # where the holding disk is
    use -30 Mb # how much space can we use on it
    }

    reserve 40 # percent

    infofile "/var/lib/amanda/site_name/curinfo" # database filename
    logdir "/var/log/amanda/site_name" # log directory


    define tapetype DellHW {
    comment "Dell Changer tested (hardware compression on)"
    length 60000 mbytes
    filemark 11 kbytes
    speed 1322 kps
    }

    define dumptype global {
    comment "Global definitions"
    # This is quite useful for setting global parameters, so you don't have
    # to type them everywhere. All dumptype definitions in this sample file
    # do include these definitions, either directly or indirectly.
    # There's nothing special about the name `global'; if you create any
    # dumptype that does not contain the word `global' or the name of any
    # other dumptype that contains it, these definitions won't apply.
    # Note that these definitions may be overridden in other
    # dumptypes, if the redefinitions appear *after* the `global'
    # dumptype name.
    # You may want to use this for globally enabling or disabling
    # indexing, recording, etc. Some examples:
    # index yes
    # record no
    }


    define dumptype normal {
    global
    program "GNUTAR"
    comment "normal backup behaviour"
    compress none
    index yes
    record yes
    priority medium
    }


    define dumptype homes {
    global
    program "GNUTAR"
    comment "homes without samba"
    compress none
    index yes
    record yes
    priority medium
    exclude "./samba"
    }



    What can I do ?


    Thank you in advance,

    ddaas

  2. #2
    Just Joined!
    Join Date
    May 2004
    Location
    Pennsylvania
    Posts
    98
    It's been a while since i've worked with amanda so i'm not sure i can help, but i'll give a shot.

    were there any problems before? or did they just start now?

    are you sure the DellHW is your changer and that /dev/fg0 is the right location that its connected to?

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    69
    There were no problem before.
    I've discovered that the backup system works no more.
    I have a tape device and a tape changer. The tape changer was no more under /proc/scsi/scsi . Maybe the server were booted with the wrong kernel version without LUN support (for scsi). I've installed a new good kernel and now I have both the tape changer and the tape drive recongnized from the kernel.

    But the the problems still persist.

    I am sure I have a DellHW and is connected in the right place because all worked before with the same config.
    Somebody else configured all so I don't know 100% of the configuration.


    What do you think?

    ddaas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •