Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I am having troubles writing CD's. I have three different HP writers, all of which I know work (or I should say, the hw is not the issue) Tried different ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2002
    Posts
    33

    cdrecord problems


    I am having troubles writing CD's. I have three different HP writers, all of which I know work (or I should say, the hw is not the issue) Tried different cd's, brands, types, etc. I have searched high and low on the internet, seen many of the same posts, but no resolution. Anybody have any ideas, fixes?

    Rehat 8.0
    2.4.18 kernel
    cdrecord 1.10-14
    IDE writers (all the correct modules loaded)

    [root@VanSwapper garett]# cdrecord -v -multi speed=2 dev=1,1,0 htmlbackup.iso
    Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 Jörg Schilling
    TOC Type: 3 = CD-ROM XA mode 2
    scsidev: '1,1,0'
    scsibus: 1 target: 1 lun: 0
    Linux sg driver version: 3.1.24
    Using libscg version 'schily-0.5'
    atapi: 1
    Device type : Removable CD-ROM
    Version : 0
    Response Format: 1
    Vendor_info : 'HP '
    Identifikation : 'CD-Writer+ 8100 '
    Revision : '1.0g'
    Device seems to be: Generic mmc CD-RW.
    Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
    Driver flags : SWABAUDIO
    Drive buf size : 1040128 = 1015 KB
    FIFO size : 4194304 = 4096 KB
    Track 01: data 2 MB
    Total size: 2 MB (00:15.81) = 1186 sectors
    Lout start: 2 MB (00:17/61) = 1186 sectors
    Current Secsize: 2048
    ATIP start of lead in: -11078 (97:34/22)
    ATIP start of lead out: 336075 (74:43/00)
    Disk type: Phase change
    Manuf. index: 11
    Manufacturer: Mitsubishi Chemical Corporation
    Blocks total: 336075 Blocks current: 336075 Blocks remaining: 334889
    Starting to write CD/DVD at speed 2 in write mode for multi session.
    Last chance to quit, starting real write in 0 seconds. Operation starts.
    Waiting for reader process to fill input buffer ... input buffer ready.
    Performing OPC...
    Starting new track at sector: 0
    Track 01: 0 of 2 MB written.cdrecord: Input/output error. write_g1: scsi sendcmd: no error
    CDB: 2A 00 00 00 00 00 00 00 1F 00
    status: 0x2 (CHECK CONDITION)
    Sense Bytes: 70 00 03 00 00 00 00 12 00 00 00 00 0C 00 00 00
    Sense Key: 0x3 Medium Error, Segment 0
    Sense Code: 0x0C Qual 0x00 (write error) Fru 0x0
    Sense flags: Blk 0 (not valid)
    cmd finished after 9.961s timeout 40s

    write track data: error after 0 bytes
    Sense Bytes: 70 00 00 00 00 00 00 12 00 00 00 00 00 00 00 00 00 00
    Writing time: 18.984s
    Fixating...
    cdrecord: Input/output error. close track/session: scsi sendcmd: no error
    CDB: 5B 00 02 00 00 00 00 00 00 00
    status: 0x2 (CHECK CONDITION)
    Sense Bytes: 70 00 05 00 00 00 00 12 00 00 00 00 24 00 00 00
    Sense Key: 0x5 Illegal Request, Segment 0
    Sense Code: 0x24 Qual 0x00 (invalid field in cdb) Fru 0x0
    Sense flags: Blk 0 (not valid)
    cmd finished after 0.002s timeout 480s
    cmd finished after 0.002s timeout 480s
    Fixating time: 0.006s
    cdrecord: fifo had 39 puts and 1 gets.
    cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Could you check for kernel message (/var/log/messages by default) that are posted at the time of the incidents?

  3. #3
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    you are trying to write cd's as a normal user with a non-setuid binary. That means nothing to newer people. Try running it as root, see if that fixes it. If so come back, I will give you some more insight as to what/why it is happening.
    I respectfully decline the invitation to join your delusion.

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    If you look at his prompt, you'll see that he was root.

  5. #5
    Just Joined!
    Join Date
    Dec 2002
    Posts
    33
    I was root, believe me. The "garett" you see is the current workng directory I was in. I have tried this on three different boxes too, different writers, different media, etc. Two Redhat 8.0's and one Slackware 8.0, same kernel rev's. This sounds like a bug somewhere. By the way, if I look at the messages file, it reports SCSI timeouts. Knowing that these IDE drives are emulating SCSI devices, this is expected. Exactly why this is happening, I am not sure yet. I also have a SCSI Travan tape drive that works without a hitch, but that is a bit different.

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    This seems kind of strange, especially since you've tried it on the different systems. On my system it has always worked as soon as I've configured ide-scsi. Although I don't really believe that this is a kernel bug, could you try upgrading to the latest 2.4 series from www.kernel.org?

  7. #7
    Just Joined!
    Join Date
    Dec 2002
    Posts
    33
    Yes it is strange. If memory serves me correct, I though Redhat 7.3 worked at one time. I do not recall what kernel rev. it was....whatever came std. with 7.3. I suppose I could try updating the kernel. I have been sucessful writing CD's in the past. I just walked over to my buddies PC with RH 8.0, same error, same kernel.

  8. #8
    Just Joined!
    Join Date
    Dec 2002
    Posts
    33
    what distro and kernel are you running?

  9. #9
    Just Joined!
    Join Date
    Dec 2002
    Posts
    33
    Just to make things a bit clearer. Here is my approach.

    User = root

    # mkisofs -R -o crap.iso /home/garett

    # cdrecord -v -multi dev=1,1,0 speed=4 or 2 crap.iso

  10. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Exactly what are the kernel message that you get?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •